5

When using Ubuntu 15.10, my headphones were auto-detected properly. Since upgrading to 16.04, that is no longer the case. I can force output to them using either pavucontrol or indicator-sound-switcher, and doing so while running pulseaudio in debug mode shows that analog-output-headphones works (obviously).

However, pavucontrol and hdajacksensetest show that headphones being plugged in are no longer detected.

What has changed in 16.04? The sound card in question uses the Realtek ALC3235 codec, using the snd-hda-intel module, from what I can tell.

Some info from dmesg as well:

snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC3235: line_outs=1 (0x16/0x0/0x0/0x0/0x0) type:line
[    2.501826] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=1 (0x14/0x0/0x0/0x0/0x0)
[    2.501829] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
[    2.501831] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    2.501832] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    2.501835] snd_hda_codec_realtek hdaudioC1D0:      Dock Mic=0x19
[    2.501837] snd_hda_codec_realtek hdaudioC1D0:      Headset Mic=0x1a
[    2.501839] snd_hda_codec_realtek hdaudioC1D0:      Internal Mic=0x13
[    2.511782] input: HDA Intel PCH Dock Mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input10
[    2.511845] input: HDA Intel PCH Dock Line Out as /devices/pci0000:00/0000:00:1b.0/sound/card1/input11
[    2.511901] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card1/input12

ALSA details: http://www.alsa-project.org/db/?f=b75391807be48e7403a2fd316c18485e15cecb2b

  • I also tried upgrading to the latest ALSA driver as mentioned here: wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS – PhilB May 5 '16 at 23:13
  • Did you try to remove ~/.config/pulse? Also make sure that module-switch-on-port-available is active (see with pactl list short modules). – Takkat May 6 '16 at 7:43
  • Yes to both. It clearly sees the sink, as I can see it in the outputs in pavucontrol (but not in sound settings, since that only shows up when it detects the headphones), but it says "unplugged", so it's the jack detection that's suddenly buggered. – PhilB May 6 '16 at 15:36
  • Well, something must have happened in an update lately, because now it works properly. Plugging in headphones even comes up with a new dialogue asking if it is a set of headphones or a headset being plugged in (something I've never seen before). – PhilB May 17 '16 at 20:11
6

I was experiencing a similar issue with 16.04 on latest Dell XPS 13 (9350). To resolve it, I ran alsamixer from cli, selected the "Headphone" channel using arrow keys, then pressing "M" to unmute (indicated by a status of "MM"). I had to also increase volume on this same channel. There was an additional channel that was causing distortion/interference once my headphones were unmuted, so I lowered that. Everything is fine after this, though I'm no longer prompted to identify the input device like I used to be on 14.04, which isn't a bad thing if it knows it's a headset.

| improve this answer | |
  • having the same issue, i launched alsamixer from cli ( as recommended ) but there was no headphone option in mute, however i selected a different option in "F6: Select sound card" and notieced <Auto-Mut> was Disabled, when i Enabled it my headphones now work properly ( in the sense that when i plug them in sound is only heard on the headphones and not the computer speakers ) but I still don't see them in my system > sound > output list :-/ – Nick Oct 3 '16 at 14:36
  • 1
    This worked. Link this to this question to save the settings: askubuntu.com/questions/50067/howto-save-alsamixer-settings – mjp Jan 23 '17 at 20:09
0

I had this problem when I installed pulseaudio and then removed it. I am not sure how to fix it myself, but installing pulseaudio might do the trick.

pulseaudio is needed for skype and maybe other programs. So maybe you removed them. Hopefully someone can comment or edit this answer to fix the problem better.

| improve this answer | |
  • pulseaudio is most certainly installed. I tried uninstalling it, no change (so I reinstalled it) – PhilB May 5 '16 at 22:46
  • Try purge and install again. Lubuntu does not have it. I am a lubuntu person. – Bhikkhu Subhuti May 5 '16 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.