1

I tried using Boot Repair and here are the results URL: http://paste2.org/ntz2PanF

I was successful with installing ubuntu alongside windows 8.1 (I installed windows 8.1 previously using a CD) but now the system automatically boots to ubuntu. I cannot figure out how to boot back to windows 8.1 (this os is my main os). It would be ideal for me to have the option to go select between windows 8.1 and ubuntu at boot time. Please let me know what you think!

I saved some useful screen shots inn this album http://imgur.com/a/ZAF96:

  • a screen-shot from gparted
  • information about the Windows boot partition sdb1
  • a screen-shot of GRUB
  • BIOS boot options ( I even tried disabling the ubuntu boot options so that only the windows boot manager can be seen. When I do this the system goes straight to the BIOS settings every time I turn on the laptop)

Other supporting information:

  • BIOS is set to boot on UEFI
  • secure boot is disabled
  • My system is the msi gt70 2oc

  • A friend of mine upgraded this laptop to windows 10 but since none of the drivers work I had to downgrade it to windows 8.1. I also
    upgraded to the latest BIOS.

Please let me know of the next steps to try to fix this problem.

Andrei

UPDATE 1: I tried using windows repair disk and enter these codes but it did not work

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

UPDATE 2: I reinstalled ubuntu over the ubuntu I had earlier. When I turned on my computer Grub shows the windows boot option but when I selected it returns me to the same Grub selection. Now, I ran boot-repair again and it removed the windows boot option in grub.

  • if you go into bios and select the windows boot manager does it boot to windows? – John Orion May 5 '16 at 19:09
  • I don't have Windows on my Ubuntu system but I did check my windows partitions on my windows machine and the "reserved" partition does show "other" for the file system so I believe the errors you see aren't real important. If you can boot to windows using the choice in bios and Windows works .. then maybe I can come up with a solution to get it to be seen by the GRUB menu – John Orion May 5 '16 at 19:26
  • John, I have tried disabling the Ubuntu options so that the system will boot to windows. When I do this it DOES NOT go to windows. Instead it goes to the BIOS settings. Did I understand your question correctly? – MrBuggy May 5 '16 at 19:33
  • In the screenshots I provided GParted tells us that the windows boot is not not mounted. Will this be the reason why we can't boot to Windows? – MrBuggy May 5 '16 at 19:36
1

Probably the upgrade to new UEFI reset all the UEFI parameters. I keep a list of changes, so I know what to reset after a UEFI update.

But you do not have an UEFI entry in UEFI for Windows. It normally saves the UEFI boot entries in its own NVRAM which is normally lost only if you disconnect a drive.

Your system is also not showing sda other than it has gpt partitioning, but no partitions?

Check entries before & after change from Ubuntu or live installer.

sudo efibootmgr -v 

if ESP sdb3, you have to specify drive (-d) & partition (-p)

sudo efibootmgr -c -d /dev/sdb -p 3 -L "Windows Boot Manager" -l "\EFI\Microsoft\Boot\bootmgfw.efi"

This was an Ubuntu entry:

Changed the UEFI motherboard on a dell laptop, now it says no OS detected

Info of efibootmgr

http://linux.die.net/man/8/efibootmgr

I also like to have another fallback or hard drive entry in /EFI/Boot/bootx64.efi. I only have Ubuntu so I copy shimx64.efi to bootx64.efi. Windows normally copies its efi boot file to bootx64.efi as a backup way to boot.

  • Fred, I do not fully understand your answer, I'm very new at Linux and Ubuntu. But I did try out the command you suggested and it showed this [link] (imgur.com/a/6iVWR). I'm not sure why there are two ubuntus here though. What are your thoughts? – MrBuggy May 5 '16 at 23:20
  • There always are two ubuntu entries. If you look close one is shim and the other grub. Shim is the secure boot version of grub or the shim between the UEFI & grub for Secure boot. But shim works when secure boot is off, so I have no idea why they still have both. Does your Windows entry in UEFI boot Windows? Try one time boot key like f10 or f12 or directly from UEFI. And can you boot Windows from grub menu? If no entry in grub menu, run this in Ubuntu: sudo update-grub – oldfred May 6 '16 at 3:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.