1

I Have installed Ubuntu Linux on my Asus X205T, using an USB WiFi, (everything went ok).

In the next step, I tried to install the wifi network driver:

wget https://android.googlesource.com/platform/hardware/broadcom/wlan/+archive/master/bcmdhd/firmware/bcm43341.tar.gz
tar xf bcm43341.tar.gz
mkdir -p /lib/firmware/brcm/
cp fw_bcm43341.bin /lib/firmware/brcm/brcmfmac43340-sdio.bin`

I can see the wifi networks around me but when I try to connect to one of them, its start rolling like to connect but in the end not connecting. I tried to do that with many different networks like a network with WPA/WPA2 password, WEP, also a network without a password.

  • 2
    Isn't the android repositories you are downloading from? Are you sure that driver is supposed to work on Ubuntu? – Dan May 5 '16 at 15:02
  • 1
    Please edit your question to add the result of this terminal command: lsusb. Welcome to askubuntu. – chili555 May 5 '16 at 15:21
  • l==> lspci <=== in terminal 00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0f) 00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0f) 00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0f) 00:1d.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series USB EHCI (rev 0f) 00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0f) – MR. AYADI May 5 '16 at 19:21
  • hellow , thank you for answering me , here that what i got when i made "lsusb" in terminal Bus 001 Device 004: ID 05e3:0610 Genesys Logic, Inc. 4-port hub Bus 001 Device 003: ID 0bda:57b5 Realtek Semiconductor Corp. Bus 001 Device 002: ID 8087:07e6 Intel Corp. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub – MR. AYADI May 5 '16 at 19:23
  • 1
    @Dan fyi the Android firmware does work in Ubuntu on this device - we were all using that until recently and this fix is still in the guides lying around. If the OP installed 16.04 there was probably no need to do that wget, because the Linux firmware repo now has the file and it comes with the 16.04 installation (and it works after adding the txt file to the same directory) – Zanna May 6 '16 at 6:46
3

I've got this device too. We need a kernel from 4* series, and both of these files in the right location for WiFi to work:

/lib/firmware/brcm/brcmfmac43340-sdio.bin
/lib/firmware/brcm/brcmfmac43340-sdio.txt

Step 1
In the past we could only get the .bin from Android, but it's now in the Linux firmware repository (and it's already in the installation with 16.04, so you can skip to step 2 if you already have brcmfmac43340.sdio.bin in the right place - I think you do from your question). If you need to get it you can do this:

sudo apt-get install git
git clone git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

and copy the file over from the created directory to the right place

sudo cp linux-firmware/brcm/brcmfmac43340-sdio.bin lib/firmware/brcm/brcmfmac43340-sdio.bin

you might want to delete the cloned directory after that, as it is quite big.

Step 2
Now the other file, which is already in the system but needs to be copied to the right place:

sudo cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcmfmac43340-sdio.txt

(If this throws a no such file... you may need to mount the directory temporarily:

mount -t efivars efivars /sys/firmware/efi/efivars

and try again)

Wi-Fi works after reboot :)

Note: you may find that the system hangs at end of boot after doing this & you have to hard reset. If this happens keep trying to boot - you will get in eventually. You can fix this by blacklisting the btsdio module (Bluetooth doesn't work anyway). Create a file and open to edit:

sudo nano /etc/modprobe.d/blacklist-btsdio.conf

Write this text in the file:

blacklist btsdio

Save and exit.

I should note that the same procedure works for F205TA

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.