0

I'm using Ubuntu 16.04 w/ Openbox 3.6.1. When I press Alt, some applications shows their menu. How I can disable this behavior, so Alt won't do anything?

  • @DKBose Firefox-based (Firefox itself, Komodo, etc.) – Defman May 5 '16 at 14:50
  • I'm using my own keybindings for everything and I don't use window's menu bar a lot. More over, I just want to make Alt don't do anything, but I would still assign another key (Super_R for example) to open the menu bar of any application. – Defman May 5 '16 at 15:19
  • @DKBose I dunno. It's something that I was able to do in Unity but not in Openbox. – Defman May 5 '16 at 15:41
  • Thought there's a setting for that. – Defman May 5 '16 at 15:42
  • I don't think it has anything to do with Openbox, but everything to do with GTK. Supposedly, you add gtk-enable-mnemonics=0 to your settings.ini or your gtkrc, but this hasn't worked for me. I'll try one more thing and let you know if it worked. – Samuel Feb 21 '17 at 7:20
0

Supposedly this can be disabled by changing a setting in the gtkrc or settings.ini files, for GTK 2 and 3 respectively. The option is gtk-enable-mnemonics, it has been deprecated, but the documentation states it still should be possible to use it. gtk-enable-mnemonics documentation entry

However, it really was removed from GTK, as this other answer states, you can view the commit's diff here.

There's a bug report for it in Nautilus' launchpad, so maybe Ubuntu will make a patch one day, although I doubt it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.