1

The above laptop is freezing up sometimes when I plug in a micro HDMI dongle.

The laptop is running Ubuntu 16.04, with very little installed, and is up-to-date as of today.

Here are a few scenarios:

  1. The LapTop is on, the HDMI is then plugged in, and the laptop freezes after a moment.
    • Nothing works other than long press of the power button.
    • In this case, there is nothing in the logs after boot of interest. They simply cease, which is consistent with the idea of a freeze.
  2. The Laptop is on, the HDMI dongle is then plugged in, the secondary screen works, but there is a log output that looks terrible. I wanted to paste it here, but it's refusing to format nicely. It's a kernel trace, with the ---cut here--- bits inserted.

  3. The Laptop is off, the HDMI is plugged in, and the laptop is turned on.

    • The 2nd display works as expected. Screen modes can be changed with no issues in the log
    • If the HDMI is re-plugged however, the above 2 scenarios reign.

I'm not sure where this should be, maybe as a bug report?

Any help, direction would be useful.

0

I was experiencing exactly the same problem with my Zenbook UX305UA...until today. This was a very annoying problem since it only has mini-HDMI output. The external monitor/tv/projector was only working if the laptop was turned on with the cable already plugged, but was freezing if connecting the cable once the system was running. Only hard power off could restart the system.

I'm using Ubuntu 14.04 (64bits). (could not update to 16.04 for compatibility issues at work). I've tried different kernels... (http://kernel.ubuntu.com/~kernel-ppa/mainline/)

In the end, installing the latest kernel v4.6-rc7-wily has finally solved the problem. Check also my previous answer in (https://askubuntu.com/a/750218/523046) to solve graphics issues on this laptop.

Hope it helps.

  • Hey, thanks for the update. I figured that since it was a kernel thing, I'd wait a little while before forcing anything. The fix is now in the main updates. So, for anyone else, this issue should be solved if you just sudo apt update && sudo apt upgrade. – Andrew Collett Jun 8 '16 at 6:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.