7

I can't run vmware 12 in my ubuntu 16.04 LTS OS. It always show vitual machine monitor failed.

Here's the screenshot

2

4 Answers 4

2

I solved this problem.

Ubuntu 16.04, VMware Workstation 12.1.0 build-3272444

  1. Disable Secure Boot in my BIOS.
  2. Run

    sudo su -      
    vmware-modconfig --console --install-all
    
2
  • Is there a way to fix this problem with secure boot enabled?
    – rafaelphp
    Jul 14, 2016 at 15:06
  • 1
    Disabling secure boot did the trick.
    – Enigma
    Mar 14, 2017 at 15:42
2

Using Charly's script on superuser.com/questions/1328401/vmware-workstation-vmmon-broken-on-ubuntu-18-04/, I was able to build the needed modules for kernel 4.15.0-29-generic on 16.04LTS. There is a typo at the end of the script, there should not be a line return between sudo ln -s /lib/x86_64-linux-gnu/libz.so.1 and /usr/lib/vmware/lib/libz.so.1/libz.so.1

Another addition I would recommend is to add sudo /etc/init.d/vmware restart command to the end of the above script.

So the actual solution script with tweaks is:

#!/bin/bash
VMWARE_VERSION=workstation-12.5.9
TMP_FOLDER=/tmp/patch-vmware
rm -fdr $TMP_FOLDER
mkdir -p $TMP_FOLDER
cd $TMP_FOLDER
git clone https://github.com/mkubecek/vmware-host-modules.git
cd $TMP_FOLDER/vmware-host-modules
git checkout $VMWARE_VERSION
git fetch
make
sudo make install
sudo rm /usr/lib/vmware/lib/libz.so.1/libz.so.1
sudo ln -s /lib/x86_64-linux-gnu/libz.so.1 /usr/lib/vmware/lib/libz.so.1/libz.so.1
sudo /etc/init.d/vmware restart

```

Sorry this isn't a comment on Charly's answer, I don't have the reputation on this account.

Note that this will only work for Workstation 12.5.9, you can easily tell which version you have by running vmware --version

0

I had the same problem, the solution was using vmware-workstation-version-12.1.1-3770994. I tried it and it worked just fine.

0

In my case, I'm running Workstation 16.0 on Ubuntu 20.10, and I needed to enroll MOK keys using MOKutil before vmware-modconfig would complete successfully.

There's a comprehensive guide here: https://develmonk.com/2020/06/06/whats-wrong-with-vmware-workstation-on-ubuntu/

Not the answer you're looking for? Browse other questions tagged or ask your own question.