If i try unmount usb drive i see this error.

Error unmounting /dev/sdb1: Command-line `umount  "/media/michal/MUZA"' exited with non-zero exit status 32 umount: /media/michal/MUZA: not mounted
  • Is the USB drive mounted at the time you try to umount it? – Hennes May 4 '16 at 18:20
up vote 1 down vote accepted

The error points to it not being mounted .. maybe its not mounted at that point. Try running gparted and switch to the usb then look at Mount Point and check where and if its mounted

Or you can type in terminal:

mount | grep ^'/dev/sdb1'

it should return

/dev/sdb1 on /media/michal/MUZA type .....

if it is mounted .. or a different path if it is mounted somewhere else

Just verified .. had a USB with the label CD_ROM and it mounted as /media/username/CD_ROM .. I removed the label and now it mounts with UUID.

If you want it to be mounted at /media/michal/MUZA you will need to change/add the MUZA label to the drive.

I was able to label it in Ubuntu using gparted .. I just went to the USB drive then .. if its mounted I right clicked and unmounted it then I right clicked again and chose Label File System .. Put in the name (name cant have any spaces in it... if you want spaces you need to use an underscore or dash) After I had the name I clicked on the green check mark to apply the settings . Once I did that for some reason I couldn't mount it but then I put it in my Windows machine .. it seemed fine and when I plugged it back in to Ubuntu it mounted as my Label and worked

If you run into a situation where you did get it to label but now instead of the label MUZA it is mounting it as MUZA2 then remove the USB and check the /media/michal folder and see if there is a left over MUZA folder in there. If so you will have to run a terminal and type

sudo rm -r -f /media/michal/MUZA

That should remove the folder and the next time you plug in your USB it should mount as the label without the 2 at the end.

  • Return this. /dev/sdb1 on /media/michal/36EEC75002B2B4B8 type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2) This usb drive before name "MUZA" now it is format to ntfs (before fat) – Swis May 4 '16 at 18:44
  • Ok so its not mounted as MUZA its using the UUID. Do you have it set to mount or is it automatic when you plug it in? – John Orion May 4 '16 at 18:46
  • This usb drive before name "MUZA" now it is format to ntfs (before fat) . Automatic mount – Swis May 4 '16 at 18:47
  • it probably doesn't have a label anymore .. if you format it again and label it MUZA i believe it will mount as MUZA instead of the UUID – John Orion May 4 '16 at 18:51
  • unfortunately it does not work – Swis May 4 '16 at 19:04

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.