0

I am trying to install an application that requires qt 5.5 or higher. I think that I have just about downloaded the Internet, and still it shows 5.2.1.

andrew@andrew-Aspire-E5-574:/usr/lib/x86_64-linux-gnu$ qmake -qt=qt5 --version QMake version 3.0 Using Qt version 5.2.1 in /usr/lib/x86_64-linux-gnu

I have downloaded the qt creater (I don't know why), there was a post saying that this might work.

I am using 14.04...

  • 1
    Updating to a new version of Qt within older Ubuntu versions is not currently supported. It might be possible to install Qt from the official qt.io site, but then you would likely need to configure your system or that app to use the new version of Qt, rather than the one that's an official part of Ubuntu. (I don't know the details of how to do this, but I assume it's technically possible.) The best method for running Qt >5.5 would probably be to update Ubuntu to version 16.04 (Xenial) which has Qt version 5.5.1 installed by default. – user533208 May 4 '16 at 13:54
0

personally i would recommend updating to 16.04 as well like the above comment as that would be the best way. however, if you cant then "maybe" you might try updating your source repository temporarily. QT5 is part of the main branch so all you need is to do is add something like:

deb http://us.archive.ubuntu.com/ubuntu xenial main

then do "apt-get update" .. install your new QT things ONLY. do not do an upgrade command if you are not running Xenial.

then you would either delete the Xenial entry or comment it out in your source list.

this is how i would go about things. it is not necessarily the right way, but it may get you what you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.