2

After upgrading from Ubuntu 14.04 to 16.04 on a Dell E6330 laptop with core I7 cpu, when running in the default Unity desktop with external USB keyboard and mouse, if I don't touch the keyboard or mouse for roughly 5 seconds the mouse apparently snoozes and it takes about 0.5 seconds of mouse motion before it resumes functioning. Brief bumps of the mouse are usually ignored and the motion is lost. The keyboard doesn't lose keystrokes and pressing a key before using the mouse prevents the mouse hesitation.

In my preferred XFCE desktop the issue is far worse. Keyboard input is also lost. Sometimes it can take several keystrokes to 'wake' the system. In some apps such as PyCharm the problem seems worse and the system is more resistant to "waking" than in other apps such as gedit.

The laptop's internal keyboard and pointer stick work fine. I'm not 100% sure about the trackpad as it can lose very slight motions after a pause but I think it might be its normal behavior.

On further testing I just discovered that if I plug my mouse into a USB port on the laptop instead of through my hub the problem goes away.

My question is does this sound like a power saving configuration issue and if so what settings or tools should I use to resolve it?

0

Have you tried plug them on other USB ports in this notebook?

Are them wired or wireless devices?

If wireless it could be low battery issue..

5
  • They are wired. And yes, the problem is only with the hub, plugging them in directly to the laptop resolves it. Unfortunately, the laptop only has 2 ports and I need more than that to also use my oscilloscope and USB to serial converter when working on microcontroller projects.
    – Todd Allen
    May 4 '16 at 14:27
  • Why don't you try replacing the hub? May 4 '16 at 17:33
  • 1
    I don't believe there is anything wrong with the hub. It was working perfectly before upgrading to the new Ubuntu distribution. I've done some further research and I believe the problem is due to a feature called USB autosuspend which appears to be handled in the kernel. I believe adding a parameter usbcore.autosuspend=-1 to the /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT line will fix the problem but am still reading/searching because I believe it should be possible to configure suspend behavior either for the hub or maybe just the keyboard and mouse connected to the hub.
    – Todd Allen
    May 7 '16 at 5:21
  • Have you already tried to rmmod and then modprobe this module? Locate it with lsmod command first if you would. May 7 '16 at 16:06
  • If this parameter usbcore.autosuspend=-1 doesn't work on /etc/default/grub, try researching it on /etc/acpid/ directory, sometimes daemons have different behavior from grub commands. And don't forget entering update-grub after working on /etc/default/grub/. May 7 '16 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.