7

Hi I recently switched from using the regular unity shell to gnome-fallback-compiz. I wanted to try out some Gnome extensions however when I went to the website (using both Chrome & Firefox), I got this error:

"We cannot detect a running copy of GNOME on this system, so some parts of the interface may be disabled. See our troubleshooting entry for more information"

to fully ensure that I was in fact running home I ran the following command:

echo $DESKTOP_SESSION and output was gnome-fallback-compiz

the next thing I did was go HERE using chrome to make sure the chrome pluggin could work, then I receive this error:

"Although GNOME Shell integration extension is running, native host connector is not detected. Refer documentation for instructions about installing connector"

Readin about an answer HERE I then installed a connector with:

$ sudo add-apt-repository ppa:ne0sight/chrome-gnome-shell $ sudo apt-get update $ sudo apt-get install chrome-gnome-shell

After this the pluggins page is simply blank:

enter image description here

how do I go about installing these Gnome extensions on my system?

3

Regarding Firefox

After visiting the Gnome Extension page you have to allow the plugin execution - otherwise your Gnome Session will not be recognized.

Therefor click on the plugin icon to the left of the Firefox addressbar and allow the execution.

enter image description here

6
  • 1
    The icon should appear if you move your mouse cursor over this area - offering the options 'Allow now' or 'allow and remember' – dufte May 4 '16 at 10:04
  • Do you use NoScript or something like this? I had the same problem, solved disabling NoScript – user307975 May 4 '16 at 10:19
  • @Pielco11 no dont have that installed. i tried disabling a bunch of Chrome extensions, and even using an incognito window, but that did not help – Kalamalka Kid May 4 '16 at 10:24
  • ok i was able to get to that icon you mentioned for Firefox, but only after installing the firefox pluggin, so what do i do now? – Kalamalka Kid May 4 '16 at 10:33
  • 1
    @dufte - please reread the question, as information has been added . both Chrome and Firefox know that gnome is installed now however in Chrome the page is blank and in Firefox there is no action to take if there is no button to install anything – Kalamalka Kid May 4 '16 at 20:01
2

Install chrome-gnome-shell depending your distro and run one time:

/usr/bin/python3 /usr/bin/chrome-gnome-shell --gapplication-service

After this the addon from chrome will detect the native plugin.

4
  • 1
    Typo; passed argument should be --gapplication-service but other than that, it worked for me on Ubuntu 17.10 – Thalis K. Nov 22 '17 at 13:38
  • Hi, I'm having the very same problem and getting this message: Although GNOME Shell integration extension is running, native host connector is not detected.......... Can u pls explain to me in details what you mean by "and the firstime execute..."??!! Sorry if I sound ignorant because I'm still exactly one week old with ubuntu and linux and hardly managing to find my way around. Thanks. – Nermeen Hussein Nov 30 '17 at 8:21
  • You should run the command one time and will work without run it every time boot your machine. pd: I updated my answer to be more explanatory – jics Nov 30 '17 at 13:33
  • This doesn't work with the Firefox snap – Robin Winslow Apr 30 '18 at 8:42
0

Regarding Google Chrome: (I just had this issue, and couldn't find a source for it)

After installing chrome-gnome-shell do a grep for 'gphhapmejobijbbhgpjhcjognlahblep' in /etc:

  • cd /etc; grep -nr "gphhapmejobijbbhgpjhcjognlahblep"

You should notice three entries, two files:

chromium/native-messaging-hosts/org.gnome.chrome_gnome_shell.json:7:    "chrome-extension://gphhapmejobijbbhgpjhcjognlahblep/",
chromium/policies/managed/chrome-gnome-shell.json:3:            "gphhapmejobijbbhgpjhcjognlahblep;https://clients2.google.com/service/update2/crx"
chromium/policies/managed/chrome-gnome-shell.json:6:                "gphhapmejobijbbhgpjhcjognlahblep"

First make directories for google chrome's counter-part:

  • sudo mkdir -p /etc/opt/chrome/native-messaging-hosts /etc/opt/chrome/policies/managed/

Then copy these files from the chromium folder, to the google-chrome folder:

sudo cp /etc/chromium/native-messaging-hosts/org.gnome.chrome_gnome_shell.json /etc/opt/chrome/native-messaging-hosts/ 
sudo cp /etc/chromium/policies/managed/chrome-gnome-shell.json /etc/opt/chrome/policies/managed/

I didn't need to restart chrome-gnome-shell, but try logging out and back in if this doesn't fix it for google-chrome.

0

Go to Chrome Web Store and search for 'gnome shell'. Add the first addon to browser and reload your gnome extension page. This will fix your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.