3

This question already has an answer here:

I have recently installed Ubuntu 16.04. Today suddenly I am seeing that it freezes during shutdown. I have no idea why this is happening.

marked as duplicate by Zanna, Eliah Kagan, pomsky, Videonauth, Eric Carvalho Oct 26 '17 at 16:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I have determined that on my 16.04 system this is caused by the service cups-browsed failing to shut down. I am in the process of figuring out how to fix this now. If I issue a sudo service cups-browsed stop before shutdown, it never hangs. – Organic Marble May 9 '16 at 20:35
  • 1
    Chaitanya Baranwal had mentioned in an answer that was since deleted for unclear reasons (though perhaps it was intended as a comment) that the method given in Ernesto Barechesto's answer to Ubuntu 16.04 hangs on shutdown/restart fixed this problem. As far as I know there isn't really any way to distinguish these questions, and an answer for one is likely to apply to the other, so I think we should make this a duplicate as @Zanna says. – Eliah Kagan Oct 25 '17 at 22:00
2

The launchpad discussion (linked below) has several suggestions you may find work for you. Assuming your cause is the same, it is suspected that swap and/or systemd are the issue. Try these possible fixes:

sudo systemctl reboot

(works occasionally for me, but not 100% of the time)

sudo swapoff -a

or even a combination of the two

sudo swapoff -a && sudo systemctl reboot

Though, when I tested this, the swapoff part took > 10 mins anyway. For shutdown, replace 'reboot' with 'poweroff.'

As a side note, I have had this same issue on my PC from Ubuntu 15.04 through the current 16.04. It is possibly connected to how long the computer has been in use. If it's been on a while, it will take a really long time to shut down or reboot (10 mins or more on a black screen or screen with a cursor).

I have found this issue reported a few places that you may find helpful:

15.04 laptop won't shutdown

Extended discussion on Launchpad

  • Thanks for replying... I must add that my system hangs during shutdown but it's very occasional.. I mean to to say some days it hangs but some days it does not hang at all.. Smooth shutdown after long hours of use as well as short time use... I tried to check system log also but I didn't understand what was the problem.... – Dibakar Bose May 15 '16 at 5:37
  • Did you try the above? I guess you would have to try it for a while since your issue is sporadic. I'm not the best at analyzing the logs so I'm not much help there. – Lil May 15 '16 at 22:45
0

I had same problem with ASUSE402SA-WX030T.

I solved installing mainline kernel 4.5.6

Update: While I solved freeze during shutdown installing 4.6 version, I experienced random ones during normal use. So I installed 4.5.6 mainline version and now everything is fine.

Steps to solve (please note that url provided can goes dark also):

mkdir kernel-4.5.6
cd kernel-4.5.6

#choose correct version for your arch
for f in linux-headers-4.5.6-040506-generic_4.5.6-040506.201606011632_amd64.deb linux-headers-4.5.6-040506_4.5.6-040506.201606011632_all.deb linux-image-4.5.6-040506-generic_4.5.6-040506.201606011632_amd64.deb
do
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.6-yakkety/$f
done

sudo dpkg -i *.deb

Reboot and you are done

0

I tried several methods including: editing /etc/default/grub, run sudo swapoff -a before shutdown, etc... But one of those worked for me.

Turning off USB 3.0 legacy mode in the BIOS worked for me.

0

I had this same problem and tried sudo swapoff -a and systemctl poweroff, which did not solve the problem. Finally, this command did fix it:

sudo service cups-browsed stop
-1

I'm a newbie. I have an old Inspiron E1405 with unresolved internal wireless issues and no installed Bluetooth. I have an external USB wireless device instead. I tried a bunch of posted answers which didn't work re restart and shutdown.

However... someone talked about BIOS settings so I looked there. I made a few changes and now it seems to work. Changes I made in the BIOS were:

  • I placed startup in auto, not simple.
  • I turned Bluetooth off in settings.
  • I shut off the wireless in the BIOS too, because I was using an external wireless USB dongle instead.

I think that was all I did, but now it seems to work. Who knew? It still is booting up well and shutting off and restarting well.

Not the answer you're looking for? Browse other questions tagged or ask your own question.