2

New build with 2 Geforce 710 cards and 3 monitors. Loaded Ubuntu 16.04. and with the standard driver all 3 monitors showed in system settings => display. But, experienced problems such as screen flicker, occasional system freezing and could not get i1Display to perform calibration. I downloaded/installed 364.19 using system settings => software & hardware but now only one display is active. Followed the steps Install Nvidia driver instead nouveau but still not working.

Interestingly, the mouse shows as an X on the other two monitors when I scroll to the left from primary monitor. However, system settings => display only shows one monitor. The monitor that display is the only monitor plugged into one of the cards. The other two monitors are both plugged into the second card.

Does anyone know how to resolve?

0
+50
sudo nvidia-xconfig

Change the settings for each of the monitors there (on the first tab you see) and make each of them active as they currently may not be. But you should also adjust the specific settings you wish for each one individually in the settings for each just below "PowerMizer".

  • Thank you for your reply, I tried this, but when I enable second monitor, it works, I can move mouse over it, but background is black and mouse cursor displays as "X" and I cant do anything there, and ubuntu settings does not displays this monitor as available. when I turn on Xinerama, GUI fails to run. – Andrey Smorodov Aug 22 '16 at 9:25
  • It sounds as if the default display manager may be taking over. Here are instructions from within Ask Ubuntu for turning off the standard/base/pre-installed display manager so that your NVidia driver can take absolute control (but it assumes lightdm is the standard display manager in use for whichever desktop you have chosen to install, so change the package name if not): askubuntu.com/questions/320666/how-do-i-kill-the-x-server That should remove the default oversight and control of your graphics devices by the Ubuntu basic display manager so that you can use only the Nvidia instead. – monkeyman_stones Aug 23 '16 at 12:47
  • Yes looks promising, I'll try to change display manager. Thanks. – Andrey Smorodov Aug 23 '16 at 13:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.