1

I recently upgraded from 15.10 to 16.04, and it completely broke my apache/wordpress/owncloud installation. While fixing wordpress, I removed owncloud. Now, if I try to install owncloud, I get the following errors:

    Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 owncloud-server : Depends: php5 (>= 5.4.0) but it is not installable
                   Depends: php5-pgsql but it is not installable
                   Depends: php5-json but it is not installable
                   Depends: php5-ldap but it is not installable
                   Depends: php5-cli but it is not installable
                   Depends: php5-cgi but it is not installable
E: Unable to correct problems, you have held broken packages.

I am installing the package from the owncloud repository for Ubuntu 16.04 here: http://download.owncloud.org/download/repositories/stable/Ubuntu_16.04/

I have read the article about the 16.04 upgrade breaking owncloud here: Ubuntu 16.04 upgrade: authorization issue

However, I have not been able to find a workaround. I would imagine I just need some way to trick owncloud to use PHP7, but I can't figure out how to do that. Does anyone have an idea of what to do?

  • What happens if you uninstall php7 (sudo apt-get remove php7-*) and then try again? – TheWanderer May 3 '16 at 22:49
1

You can make sure that you are installing

sudo apt-get install owncloud owncloud-deps-php7.0 owncloud-files

Maybe just install owncloud doesn't install owncloud-deps-php7.0

When I was having the issue that you linked here ... I had the 15.10 repository installed not the 16.04 .. there wasn't a 16.04 when I was trying to fix it. If the above doesn't work. I would try going into your

/etc/apt/sources.list.d 

find the owncloud one and change the number from 16.04 to 15.10 or maybe even 15.04 and then

sudo apt-get update 

and then try to install

sudo apt-get install owncloud-files

first and if that doesn't work try installing

sudo apt-get install owncloud  

If it will install that way .. after install I would go back and re-update your owncloud.list back to 16.04 and another apt-get update .. then see if there is an update to it and try to update

  • No dice. owncloud-deps-php7.0 cannot be found. reverting to 15.10 repository and installing owncloud-files still results in the same error after trying to install owncloud-server. sudo apt-get install owncloud owncloud-deps-php7.0 owncloud-files Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package owncloud-deps-php7.0 E: Couldn't find any package by glob 'owncloud-deps-php7.0' E: Couldn't find any package by regex 'owncloud-deps-php7.0' – Steven Farnell May 13 '16 at 1:10
  • I found out what my problem was. At some point while fiddling with stuff my repository was set to 8.2 rather than stable. After opening /etc/apt/sources.list.d/owncloud.list file, I was able to fix the repository url to match the original post. Next, I was able to update then install owncloud-deps-php7.0, finally, install owncloud worked. – Steven Farnell May 13 '16 at 1:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.