1

I am able to establish a connection between a Bluetooth ear-piece and the Bluetooth controller in the PC. The problem is that the O/S does not provide an option to send audio output to the Bluetooth controller - this is a Bluetooth controller firmware issue. Basically I am not able to load the *.hcd file I made from a *.hex file into the kernel (my interpretation of this issue with my very limited understanding).

Image #1 - Bluetooth is connected to Bluetooth card in PC (screen shot is of 'blueman' software as suggested in Bluetooth won't find devices!): enter image description here

Image #2 - Core of problem, no option to output sound to connected Bluetooth device: enter image description here

Image #3 - when I run dmesg | grep -i blue the result is as follows (confirms the issue is a firmware problem):

firmware issue image

I have spent over 8 hours looking through posts on this issue, and I can say that out of very many posts with similar unanswered issues, there is a gem which explains how to fix this issue. Have a look: Bluetooth Broadcom 43142 isn't working I followed this instruction manual to the T! The only problem is that it didn't work for me. The image below shows the final step of the solution to the post I linked to. Now, does it not work for me because the *.hcd needs to go to a different location (as everything else is *.bin) in addition to this location? Could it be the naming of the hcd file? Is there some command to force load the *.hcd file into the kernel? do I need to remove some other piece of software? Can I load the driver I created using 'System Settings' > 'Software and Updates' > drivers tab?enter image description here

It seems that all that needs to be done is to somehow load the compiled hex file (hcd file) into the damn kernel. Any advice?

Other stuff I tried is:

  1. Checked BIOS to make sure Bluetooth is enabled
  2. Ran a bunch of commands I read about in a sea of Bluetooth heartbreak, but nothing worth mentioning here
  3. Also, no wireless signals have been disabled: enter image description here
  4. Kernel Version: creator@PC-W530_Linux:~$ uname -a Linux PC-W530_Linux 3.13.0-85-generic #129-Ubuntu SMP Thu Mar 17 20:50:15 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

If you need me to run any commands please let me know. Thanks!

********************************Edit #1**************************************

Some more commands:

enter image description here enter image description here

  • Please edit your question and add output of lsusb; lspci -knn | grep Net -A2 terminal command. – Pilot6 May 4 '16 at 7:11
  • @Pilot6 - First off.... Thank you for taking the time to respond!!!! I really appreciate it. It just so happens that I figured out the problem - Your solution works perfect, unless you have 'blueman' installed! As soon as I got rid of blueman the bluetooth works. I will put the answer up in case someone else has this issue. Thanks again! – Mike May 4 '16 at 11:45
2

To fix the issue of firmware not working for a Broadcom Bluetooth you need to perform two steps (1) see: Bluetooth Broadcom 43142 isn't working, and (2) uninstall 'Blueman'.

In my post I already worked through Pilot6's fix (step 1); but my bluetooth device was still not playing music (Was connected but still not playing music). Next I uninstalled blueman using software center:

enter image description here

At this point do a restart. After the restart there will only be one bluetooth logo (instead of two) enter image description here

At this time pair the chosen device as usual. Now when you go to sound settings, you will see the Bluetooth device.

enter image description here

A massive thanks to Pilot6, first for posting a working solution, and second for responding when I asked for help. Thank You! Too bad the blueman software breaks the firmware used by the O/S, the blueman interface is really nice. Well problem fixed.... Hope this is of help to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.