1

This question already has an answer here:

I'm new (again) to ubuntu. I tried a few years ago and then never actually used it again. Now I'm trying again. I use dreamweaver on Windows because it has a nice side by side view of the code and the WYSIWYG, and can also manage a project. I remembered Kompozer being able to do these things as well, so tried installing it. I'm aware that Kompozer has stopped and is no longer being maintained, but I couldn't find any alternative that has these two options so started to try anyway. Following the instructions on https://help.ubuntu.com/community/InstallKompozer I managed to get it working, but when I perform a software update it gets removed again. I also get the 'Error Broken count >0' notification, and cannot update until I remove kompozer again.

While installation the only error I get is that libidl0 is not installed. When I try to install it, I get the message that it has been replaced by libidl-2-0:i386 libidl-2-0. I've installed these two packages but it doesn't solve the problem.

Any help for this newbie?

marked as duplicate by David Foerster, karel, terdon Oct 6 '16 at 9:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I don't have a direct answer for you, but I want to let you know about bluegriffon.org , a very similar program that is available for Ubuntu and still being updated. – user533208 May 3 '16 at 18:03
  • Thanks for comment. I had a look at bluegriffon, but it doesn't have a split view, and cannot manage a project. – stikpet May 9 '16 at 5:18
  • Please edit your question to include the problematic command as well as its full verbatim output. To capture the output you can either 1) select, copy & paste the terminal content or 2) save it to a file and use that. Longer listings (>100 lines) should be uploaded to a pastie service and linked to in the question. Thanks. – David Foerster Oct 4 '16 at 13:11
2

It is still possible to do, although a little convoluted:

  1. The package libidl0 is no longer present in Xenial; you can still find it in Trusty. You therefore have to install it manually. Go to http://packages.ubuntu.com/trusty/libidl0 and download the file for your architecture (i. e. amd64 for 64 bit systems) and install it.

  2. Then you can follow the original instructions minus the libidl0 package installation.


The installation can be abridged to just two commands once you have the three Deb package files in the current working directory:

sudo dpkg -i libidl0_*.deb kompozer_*.deb kompozer-data_*.deb
sudo apt install -f

The first will likely end in a missing dependencies error which the 2nd command will fix.

  • 1
    No longer works. lnstallation of libidl0 causes requirement to install libidl-common. Installation of libidl-common causes removal of libidl0! – John Rose Jan 16 '17 at 6:58
  • On new installation of 18.04, libidl0 problem problem is fixed but now getting kompozer depends on libpango1.0-0 (>= 1.14.0); however: Package libpango1.0-0 is not installed. That is fixable as per my Answer in askubuntu.com/questions/832913/…. – John Rose Sep 1 '18 at 7:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.