0

After installing Ubuntu via a USB and restarting the computer it only boots windows. I checked on the BIOS and Ubuntu doesn't appear. I can boot into Ubuntu using the USB: it boots the menu: try Ubuntu, install Ubuntu, etc. then I press Esc and it shows the GRUB terminal, then I enter exit and the boot management appears. There, I can select Ubuntu which actually appears as a booting option (It doesn't in BIOS) and it runs the GRUB where I can select either Ubuntu or Windows.

I tried the boot repair inside Ubuntu and this is the report link: http://paste2.org/ykpn6NvZ

Thanks in advance.

0
=> No boot loader is installed in the MBR of /dev/sda.
=> No known boot loader is installed in the MBR of /dev/sdb.

So you don't have boot loader on the root partition of your hard drive and

Number  Start   End    Size    File system     Name                          Flags
1      1049kB  473MB  472MB   ntfs            Basic data partition          hidden, diag
2      473MB   578MB  105MB   fat32           EFI system partition          boot, esp
3      578MB   595MB  16.8MB                  Microsoft reserved partition  msftres
4      595MB   689GB  689GB   ntfs            Basic data partition          msftdata
5      689GB   742GB  52.3GB  ext4
6      742GB   750GB  8518MB  linux-swap(v1)

boot flag is set to the second fat32 partition.

Device          Start        End    Sectors   Size Type
/dev/sda1        2048     923647     921600   450M Windows recovery environment
/dev/sda2      923648    1128447     204800   100M EFI System
/dev/sda3     1128448    1161215      32768    16M Microsoft reserved
/dev/sda4     1161216 1346364490 1345203275 641.5G Microsoft basic data
/dev/sda5  1346365440 1448511487  102146048  48.7G Linux filesystem
/dev/sda6  1448511488 1465147391   16635904     8G Linux swap

Suggested idea: install grub loader on /dev/sda

sudo grub-install /dev/sda

using Boot-Repair advanced menu, place the boot flag to /dev/sda (i.e. grub and boot flag should be set on the same partition).

boot-repair boot flag

  • The boot flag option doesn't appear on my grub options. Is ther any other way to change it? – Josep Planells May 3 '16 at 19:49
  • @JosepPlanells While googling for it, i found that looks like there is no need to change the boot flag for linux. (If you still need it sudo sfdisk -A2 /dev/sda will do it) Installing grub on /dev/sda should be enough. Read please this article – Slowpoke May 3 '16 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.