A few days ago, I upgraded the kernel to 4.5.2 (I run Ubuntu Mate 14.04 LTS) and my ASUS USB-N13 Wi-Fi dongle now isn't working properly.

I tried to add in:

sudo nano /etc/sysctl.conf

These lines:

net.ipv4.tcp_syncookies = 1
net.ipv4.tcp_window_scaling = 0
net.ipv4.tcp_ecn = 0

And after in a terminal I entered:

sudo /etc/init.d/networking restart
sudo iwconfig
sudo iwconfig wlan0 rate 54M

But it remains on 1M with the error Cannot set bit rate.

Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device wlan0

closed as off-topic by David Foerster, Zanna, Pilot6, Eric Carvalho, karel Apr 25 '17 at 4:38

  • This question does not appear to be about Ubuntu within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to AskUbuntu! Could you please run the network diagnostics and edit your question to include a link to the result? I know it may seem a bit overwhelming for a novice but your info so far is a bit vague and the diagnostics will likely cover all options that may cause your issue. Thanks. – David Foerster Apr 23 '17 at 19:11
  • 2
    I'm voting to close this question as off-topic because issues with unsupported kernels are off-topic. – Pilot6 Apr 24 '17 at 10:19

Try this:

sudo -H gedit /etc/network/interfaces

and add the line: wireless-rate 54M

Restart. It could work, sometimes your adapter doesn't take this configuration, so you can try this:

sudo -H gedit /etc/NetworkManager/system-connections/

This will open your Wifi connection configuration, then add the following after "mode":

rate=Auto or rate=54M

Not the answer you're looking for? Browse other questions tagged or ask your own question.