102

This question already has an answer here:

When I run the command:

sudo apt-get update

I got this following warning:

There is no public key available for the following key IDs: 1397BC53640DB551

This is the only warning I got and I do not get any Error.

How I can fix it and what the key 1397BC53640DB551 is all about?

marked as duplicate by David Foerster, Luís de Sousa, Eric Carvalho, Seth May 12 '16 at 18:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

147

I resolved running:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1397BC53640DB551

The command above download the missing key using the hexadecimal numbers given in the error (1397BC53640DB551) with apt-key. After running apt-key to download the missing PUBKEY, any packages from that repositories will be considered trusted.


It seems to be a known problem in chromium that is being worked on (check here). They are working to remove SHA1 encryption (link).

Another possible workarounds that have been posted on reddit

wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Looking at this, seems that Google now has two keys, and the old one will probably be discontinued along with SHA1.

  • 2
    The first one timed out for me (keyserver.ubuntu.com) so I had to use the second one from Google. – Ryan H. Sep 4 '16 at 17:42
  • 1
    If you're in an IPv6 only server, you can use pool.sks-keyservers.net instead of keyserver.ubuntu.com – James Z Aug 28 '17 at 18:11
  • Working fine when I can't add inkscape trunk in this tutorial inkscape.org/es/gallery/item/6641/view The error appear: "W: GPG error: ppa.launchpad.net/inkscape.dev/trunk/ubuntu xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9DA4BD18B9A06DE3 " Then I Add with this: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 9DA4BD18B9A06DE3 – Indacochea Wachín Feb 21 at 3:54
41

Correct command line is:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1397BC53640DB551

Not the answer you're looking for? Browse other questions tagged or ask your own question.