2

I'm currently running on Ubuntu 15.10, but I want to update to 16.04. But the updater says I have broken packages. But, in my opninion, I have way too much broken packages and I have no idea why they became broken...

When I use Synaptic Package Manager and I click Edit > Fix Broken Packages, but that does nothing, doesn't even show anything.

Here is the output of my broken packages:

Broken perl-base:amd64 Breaks on perl-modules [ amd64 ] < 5.20.2-6ubuntu0.2 > ( perl ) (< 5.22.1~)
Broken perl-base:amd64 Breaks on perl-modules [ i386 ] < none > ( none ) (< 5.22.1~)
Broken findutils:amd64 Breaks on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (< 3.4.4-2)
Broken libgnome-desktop-3-12:amd64 Breaks on libgnome-desktop-3-10 [ amd64 ] < 3.16.2-2ubuntu2 > ( libs )
Broken libmwaw-0.3-3:amd64 Conflicts on libmwaw-0.3-3v5 [ amd64 ] < 0.3.5-1ubuntu1 > ( libs )
Broken libodfgen-0.1-1:amd64 Conflicts on libodfgen-0.1-1v5 [ amd64 ] < 0.1.4-1ubuntu1 > ( libs )
Broken unity-control-center-faces:amd64 Conflicts on gnome-control-center-shared-data [ amd64 ] < 1:3.16.3-0ubuntu1 > ( gnome )
Broken php-cli:amd64 Depends on php7.0-cli [ amd64 ] < none -> 7.0.4-7ubuntu2 | 7.0.5-2+deb.sury.org~wily+1 > ( php )
Broken unity-lens-music:amd64 Conflicts on unity-scope-musicstores [ amd64 ] < 6.9.0+15.04.20141219-0ubuntu1 > ( gnome )
Broken php-json-schema:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken python3-click-package:amd64 Conflicts on python3-click [ amd64 ] < 0.4.39.1+15.10.20150702-0ubuntu2 -> 6.2-2ubuntu1 > ( universe/python )
Broken libmono-corlib2.0-cil:amd64 Depends on mono-runtime [ amd64 ] < 3.2.8+dfsg-4ubuntu4 -> 4.2.1.102+dfsg2-7ubuntu4 > ( interpreters ) (< 3.2.9)
Broken jsonlint:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken libmono-i18n-west2.0-cil:amd64 Depends on libmono-corlib2.0-cil [ amd64 ] < 3.2.8+dfsg-4ubuntu4 > ( cli-mono ) (>= 3.2.8)
Broken libpython3.4-stdlib:amd64 Depends on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)
Broken libmetacity-private3a:amd64 Breaks on libmetacity-private3 [ amd64 ] < 1:3.17.2-4ubuntu1 > ( libs ) (< 1:3.18)
Broken composer:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken libmono-system2.0-cil:amd64 Depends on libmono-corlib2.0-cil [ amd64 ] < 3.2.8+dfsg-4ubuntu4 > ( cli-mono ) (>= 3.2.8)
Broken libcdr-0.1-1:amd64 Conflicts on libcdr-0.1-1v5 [ amd64 ] < 0.1.1-2ubuntu1 > ( libs )
Broken libmono-security2.0-cil:amd64 Depends on libmono-corlib2.0-cil [ amd64 ] < 3.2.8+dfsg-4ubuntu4 > ( cli-mono ) (>= 3.2.8)
Broken libcheese7:amd64 Depends on cheese-common [ amd64 ] < 3.16.1-1ubuntu2 -> 3.18.1-2ubuntu3 > ( gnome ) (= 3.16.1-1ubuntu2)
Broken tzdata-java:amd64 Depends on tzdata [ amd64 ] < 2016d-0ubuntu0.15.10 -> 2016d-0ubuntu0.16.04 > ( libs ) (= 2016d-0ubuntu0.15.10)
Broken libmono-posix2.0-cil:amd64 Depends on libmono-corlib2.0-cil [ amd64 ] < 3.2.8+dfsg-4ubuntu4 > ( cli-mono ) (>= 3.2.8)
Broken libwpd-0.10-10v5:amd64 Depends on libwpd-0.10-10 [ amd64 ] < 0.10.0-2ubuntu4 -> 0.10.1-1ubuntu1 > ( libs ) (= 0.10.0-2ubuntu4)
Broken xserver-xorg-input-mouse:amd64 Depends on xorg-input-abi-21 [ amd64 ] < none > ( none )
Broken libperl5.20:amd64 Depends on perl-base [ amd64 ] < 5.20.2-6ubuntu0.2 -> 5.22.1-9 > ( perl ) (= 5.20.2-6ubuntu0.2)
Broken libmono-corlib4.0-cil:amd64 Depends on mono-runtime [ amd64 ] < 3.2.8+dfsg-4ubuntu4 -> 4.2.1.102+dfsg2-7ubuntu4 > ( interpreters ) (< 3.2.9)
Broken libcheese-gtk23:amd64 Depends on libcheese7 [ amd64 ] < 3.16.1-1ubuntu2 > ( libs ) (>= 3.4.0)
Broken libplank0:amd64 Depends on libplank-common [ amd64 ] < 0.10.1-1 -> 0.11.1-1 > ( universe/utils ) (= 0.10.1-1)
Broken libhunspell-1.3-0v5:amd64 Depends on libhunspell-1.3-0 [ amd64 ] < 1.3.3-3ubuntu3 -> 1.3.3-4ubuntu1 > ( libs ) (= 1.3.3-3ubuntu3)
Broken checkbox-ng-service:amd64 Depends on checkbox-ng [ amd64 ] < 0.20.1-1 -> 0.23-2 > ( utils ) (= 0.20.1-1)
Broken findutils:amd64 Breaks on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (< 3.4.4-2)
Broken openjdk-7-jre-headless:amd64 Depends on tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java )
Broken libpython3.4-stdlib:amd64 Depends on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)
Broken php-composer-spdx-licenses:amd64 Breaks on composer [ amd64 ] < 1.0.0~alpha10+20150602-1 -> 1.0.0~beta2-1 > ( universe/php ) (< 1.0.0~alpha11)
Broken composer:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken tzdata-java:amd64 Depends on tzdata [ amd64 ] < 2016d-0ubuntu0.15.10 -> 2016d-0ubuntu0.16.04 > ( libs ) (= 2016d-0ubuntu0.15.10)
Broken findutils:amd64 Breaks on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (< 3.4.4-2)
Broken openjdk-7-jre-headless:amd64 Depends on tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java )
Broken libpython3.4-stdlib:amd64 Depends on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)
Broken php-composer-spdx-licenses:amd64 Breaks on composer [ amd64 ] < 1.0.0~alpha10+20150602-1 -> 1.0.0~beta2-1 > ( universe/php ) (< 1.0.0~alpha11)
Broken composer:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken python3.4:amd64 Depends on libpython3.4-stdlib [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)
Broken python3.4-minimal:amd64 Depends on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)
Broken tzdata-java:amd64 Depends on tzdata [ amd64 ] < 2016d-0ubuntu0.15.10 -> 2016d-0ubuntu0.16.04 > ( libs ) (= 2016d-0ubuntu0.15.10)
Broken libpython3.4:amd64 Depends on libpython3.4-stdlib [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)
Broken openjdk-7-jre-headless:amd64 Depends on tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java )
Broken php-composer-spdx-licenses:amd64 Breaks on composer [ amd64 ] < 1.0.0~alpha10+20150602-1 -> 1.0.0~beta2-1 > ( universe/php ) (< 1.0.0~alpha11)
Broken composer:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken openjdk-7-jre:amd64 Depends on openjdk-7-jre-headless [ amd64 ] < 7u95-2.6.4-0ubuntu0.15.10.2 > ( java ) (= 7u95-2.6.4-0ubuntu0.15.10.2)
Broken openjdk-7-jdk:amd64 Depends on openjdk-7-jre [ amd64 ] < 7u95-2.6.4-0ubuntu0.15.10.2 > ( java ) (= 7u95-2.6.4-0ubuntu0.15.10.2)
Broken php-composer-spdx-licenses:amd64 Breaks on composer [ amd64 ] < 1.0.0~alpha10+20150602-1 -> 1.0.0~beta2-1 > ( universe/php ) (< 1.0.0~alpha11)
Broken composer:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken php-composer-spdx-licenses:amd64 Breaks on composer [ amd64 ] < 1.0.0~alpha10+20150602-1 -> 1.0.0~beta2-1 > ( universe/php ) (< 1.0.0~alpha11)
Broken composer:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken php-composer-spdx-licenses:amd64 Breaks on composer [ amd64 ] < 1.0.0~alpha10+20150602-1 -> 1.0.0~beta2-1 > ( universe/php ) (< 1.0.0~alpha11)
Broken composer:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken php-composer-spdx-licenses:amd64 Breaks on composer [ amd64 ] < 1.0.0~alpha10+20150602-1 -> 1.0.0~beta2-1 > ( universe/php ) (< 1.0.0~alpha11)
Broken composer:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken php-composer-spdx-licenses:amd64 Breaks on composer [ amd64 ] < 1.0.0~alpha10+20150602-1 -> 1.0.0~beta2-1 > ( universe/php ) (< 1.0.0~alpha11)
Broken composer:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )
Broken php-composer-spdx-licenses:amd64 Breaks on composer [ amd64 ] < 1.0.0~alpha10+20150602-1 -> 1.0.0~beta2-1 > ( universe/php ) (< 1.0.0~alpha11)
Broken composer:amd64 Depends on php-cli [ amd64 ] < none -> 1:7.0+35ubuntu6 > ( php )

How do I fix all this? Thanks

  • try to sudo apt install -f – LittleByBlue May 3 '16 at 11:11
  • try running this command sudo apt-get update && sudo apt-get install -f – user257256 May 3 '16 at 11:12
  • 1
    @HoussemGuesmi use apt, as apt-get is being replaced with apt on 16.04. – LittleByBlue May 3 '16 at 11:15
  • @LittleByBlue ther is no source saying that apt-get is being replaced in fact both work still and will work still at least until EOL of 16.04. – Videonauth May 3 '16 at 11:25
7

Usually the reason for this issue is due to a failed/interrupted package update.

If caused by dependencies:

sudo apt-get clean
sudo apt-get install -f
sudo dpkg --configure -a
sudo apt-get update

If you get you recieved one of the following errors:

  • Encountered a section with no Package: header
  • Problem with MergeList…
  • The package lists or status file could not be parsed or opened.

Remove and rebuilt the package lists:

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update

If you get the following error

  • Could not get lock /var/cache/apt/archives/lock – open (11: Resource temporarily unavailable)

The try the following

sudo fuser -cuk /var/lib/dpkg/lock
sudo rm -f /var/lib/dpkg/lock
sudo fuser -cuk /var/cache/apt/archives/lock
sudo rm -f /var/cache/apt/archives/lock

If due to ‘Unmet dependencies for installed packages’, fix in the ‘Synaptic Package Manager.’:

  1. Open Synaptic Package Manager
  2. Click ‘Status’ (left side)
  3. Choose ‘Broken’
  4. Remove the broken packages
  • You are my hero! No more broken packages, it's all fixed! Thank you so much. – Mason May 3 '16 at 12:42
  • Awesome, glad I could help you @Mason ! :) – tekNorah Jul 7 '16 at 5:02
  • Mason, I have almost the exact same set of broken packages. Could you indicate what set of commands provided by @tekNorah fixed your issue? – Alex Jul 13 '16 at 17:06
  • @Alex the set of commands, provided by @tekNorah, that fixed my issue were sudo apt-get clean sudo apt-get install -f sudo dpkg --configure -a sudo apt-get update and sudo rm /var/lib/apt/lists/* -vf sudo apt-get update – Mason Aug 15 '16 at 10:46
0

Everytime i ran "sudo apt-get update" i saw a bunch of IGN/ignores..so I manually modified the sources list (sudo gedit /etc/apt/sources.list) and updated the list names using I regenerated from https://repogen.simplylinux.ch/generate.php

or just copy these in:

Ubuntu Main Repos
deb http://us.archive.ubuntu.com/ubuntu/ artful main restricted universe multiverse 
deb-src http://us.archive.ubuntu.com/ubuntu/ artful main restricted universe multiverse 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.