I'm using Ubuntu 14.04 and Mozilla Firefox browser.

When I go to YouTube its default is 720p (HD) but when I try to change it the check mark goes to the quality I pick but it doesn't change. It is still on 720p:

How can I select a lower quality?

  • A screenshot would be helpful May 3 '16 at 10:06
  • i.imgur.com/40j64Xm.png
    – John
    May 3 '16 at 10:09
  • I could switch to 1080HD on the same clip. So it is something with your Firefox or internet speed. I think if the connection is too slow, it is hard to switch to higher resolution. Try lower resolution and see if it switches. And try another browser, Chrome for example. May 3 '16 at 10:21
  • try this addon.
    – kashish
    May 3 '16 at 10:26
  • biocyberman, my problem is i can only switch in HD. What I want is to switch to a lower quality.
    – John
    May 3 '16 at 10:32

Check these two threads. I quoted the relevant sections for your convenience:



Either set media.mediasource.enabled and media.mediasource.webm.enabled to true in Firefox's about:config or install flash-player.




Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems:

Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Another method from the same thread

Dear, Everyone who cares. I've had the same solution on and off for weeks, and I have just now found my solution. Try LOGGING OFF. Something in the account settings was doing it for me, but Logging off of my youtube / gmail account fixed this problem.

Spread the word.

  • First option, both are already set to true, tried the others and still not working.
    – John
    May 4 '16 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.