0

My laptop is Lenovo thinkpad edge e530c. I was trying to boot Ubuntu 16.04 amd64 ISO from Grub. So I created the following menu entry for Ubuntu ISO in /etc/grub.d/40_custom file on the current ubuntu system.

menuentry "ubuntu-16.04-desktop-amd64.iso" {
 set isofile="/downloads/ubuntu-16.04-desktop-amd64.iso"
 loopback loop (hd1,9)/$isofile
 linux (loop)/casper/vmlinuz.efi boot=casper iso-scan/filename=$isofile quiet noeject nopromt spalsh --
 initrd (loop)/casper/initrd.lz
}

The iso file is located at the downloads folder on /dev/sdb9. My computer has 3 hard drives attached.

However, when I rebooted my laptop, Grub said: disk loop not found. So I thought I need to change hd1 to hd0 or hd2 because Grub may recognise hard drive differently from fdisk utility.

After I tried to change this value and boot again, the monitor went totally black. I rebooted again, there's no lenovo sign, nothing. It's totally black screen. I can not enter UEFI firmware. I had set my laptop to boot in UEFI mode only. CSM is disabled.

So was Grub causing this problem? Is my motherboard dead?

  • A lot depends on which drive you boot from. With UEFI/BIOS the boot drive is always hd0 in grub. But with UEFI you almost always boot from drive that is sda. BIOS/grub Drive order hd0, hd1, hd2, may not match mounted drive order in Ubuntu. I do not think you have a /downloads folder unless that is in a separate partition. If in /home and becuase /home is not mounted you probably need full path. I normally create a separate partition for all my ISO, so path (but maybe not drive) is a bit more straightforward. – oldfred May 4 '16 at 0:02
  • @oldfred My /dev/sdb9 has a downloads folder which was created manually by me. – LinuxBabe May 4 '16 at 0:41
0

EFIs sometimes get very confused and refuse to boot. In some cases, unplugging all the disk devices can work past this sort of problem. With all disks unplugged, the computer should launch its setup utility, which you can generally use to reset the firmware settings to the defaults. (The details of how to do this vary from one computer to another.) The problem with this is that it usually wipes out the NVRAM entries that enable you to boot any OS, so you may need to use recovery tools to do so. Some EFIs enable you to launch EFI programs you select using a file selection tool. In other cases, you may need to use a recovery disk. An Ubuntu install disk can work for this; it will enable you to boot to a working system, where you can use efibootmgr to re-create a working entry. Another option is to use my rEFInd boot manager on a USB flash drive or CD-R to boot your regular system, and then use efibootmgr to re-create your regular boot entry.

There's a small chance that your computer is completely "bricked." Such things have been known to happen, but mostly with EFIs from 3-5 years ago, which were often quite buggy. (Some Samsungs achieved notoriety for a bug that could cause them to brick themselves.)

| improve this answer | |
  • I unplugged all my disk drives but it's still black screen. No setup utility was seen. – LinuxBabe May 4 '16 at 0:10
  • I found that the way to reset firmware settings to the defaults on Lenovo thinkpad is removing battery and AC adapter, then push the power button 10 times at 1 second intervals, then push and hold the power button for 30~40 seconds. I tried this to no avail. – LinuxBabe May 4 '16 at 0:16
  • It sounds like it may be time to send the computer in for repair, then. :-( – Rod Smith May 4 '16 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.