I upgraded to Ubuntu 16.04 LTS. But the libqt4-core and libqt4-gui packages are missing.

How could I install these packages on 16.04?


These libqt4-core and libqt4-gui packages don't exist anymore in Ubuntu 16.04 LTS and newer. They were dummy packages with dependencies to other packages. The following procedure will modify the Vidyo package so it uses working dependencies.

  1. First make sure that all required libqt4 packages not installed by default are installed:

    sudo apt install libqt4-designer libqt4-opengl libqt4-svg libqtgui4 libqtwebkit4
  2. Create a script to modify the dependency defined in the package. Use the videbcontrol script provided here.

  3. Run the script videbcontrol VidyoDesktopInstaller-ubuntu64-TAG_VD_3_6_3_017.deb that will open the dependencies in a vi editor

  4. Replace Depends: libxss1,libaudio2,libasound2,libqt4-gui (>= 4.8.1), libqt4-network with Depends: libxss1,libaudio2,libasound2,libqt4-designer,libqt4-opengl,libqt4-svg,libqtgui4,libqtwebkit4,libqt4-network. This creates a file named VidyoDesktopInstaller-ubuntu64-TAG_VD_3_6_3_017.modified.deb containing the new dependency.

    If you don't know vi, once you see the package information

    1. move the cursor using the arrows down to the line starting with Depends:
    2. type the letter i to get into insert mode
    3. copy past (right click) the new line and type return
    4. type escape to leave the insert mode
    5. type dd to delete the old Depends line
    6. type ZZ to save and quit the change (two upper case z)
  5. Install the Vidyo package by executing the command:

    sudo apt install VidyoDesktopInstaller-ubuntu64-TAG_VD_3_6_3_017.modified.deb


  • Vidyo = facepalm
    – xealits
    Mar 6 '18 at 15:52

Thanks to https://ubuntuforums.org/showthread.php?t=110458 and @chmike These dependencies already have higher versions as I found. It is okay to change the .deb file instead. @bean1975 has a shorter method:

dpkg-deb -x yourfile.deb newdir 
dpkg-deb --control yourfile.deb newdir/DEBIAN
gedit newdir/DEBIAN/control

and change the libqt4-gui (>= 4.8.1) with libqt4-designer,libqt4-opengl,libqt4-svg,libqtgui4,libqtwebkit4

dpkg -b newdir modified.deb

and you can use it now!!!


Try this as it worked for me:

sudo apt-get -f install

This was suggested by terminal itself and it did some magic and what not.


I found these instructions from the Vidyo website, the easiest to follow. They have worked consistently across a few upgrades.


Linked on Ubuntu section of Launchpad:



You can install a .deb (Debian binary package) using dpkg: sudo dpkg -i libqt4-core_4.8.6...ubuntu8_amd64.deb

  • Do I have to download the files and dependencies manually? Is it there any PPA to make the install easier?
    – Enze Chi
    May 6 '16 at 22:55
  • I go dependency issue when install them:dpkg: dependency problems prevent configuration of libqt4-dbus:amd64: libqt4-dbus:amd64 depends on libqtdbus4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8); however: Version of libqtdbus4:amd64 on system is 4:4.8.7+dfsg-5ubuntu2. libqt4-dbus:amd64 depends on qdbus (= 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8); however: Version of qdbus on system is 4:4.8.7+dfsg-5ubuntu2.
    – Enze Chi
    May 6 '16 at 22:57
  • That says your libqtdbus4 package is too new. Do you have another package that broke after the update that depends on libqt4-[core|gui]? For xenial there is a package libtcore4 and linbqtgui4
    – neofug
    May 8 '16 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.