95

I have been receiving notifications about "failure to download extra data files" from update notifier. It asked me to download fonts in request from the ttf-mscorefonts-installer package. However, whenever I click on the "run this action now", a window pop up (see figure below) and it never got downloaded.

enter image description here

It keeps "waiting for headers" until timeout. Same thing will happen if I use the wget in terminal to download the package:

wget downloads.sourceforge.net/corefonts/andale32.exe
--2016-05-02 11:57:32--  http://downloads.sourceforge.net/corefonts/andale32.exe
Resolving downloads.sourceforge.net (downloads.sourceforge.net)... 216.34.181.59
Connecting to downloads.sourceforge.net (downloads.sourceforge.net)|216.34.181.59|:80... connected.
HTTP request sent, awaiting response... 

It will fail again.

I have noticed similar issues like this one, but the known solutions never worked on me. The wired thing is that I can download the font package from a browser like Chrome, and run the following command to fix the font problem:

sudo dpkg-reconfigure ttf-mscorefonts-installer

with the fonts folder directed. But my question is do I have any problem with my package-data-downloader and terminal configuration? The sudo apt-get update command can run with a few errors and warning showing that but generally it can download data from internet. It only fails when the terminal connect to sourceforge or maybe similar websites.

Hopefully you have some idea on how to make the download from terminal work for all cases. Let me know what else information I can provide. Thanks!

  • 1
    You shouldn't need to use sudo on wget, unless you're writing to a location that needs root access. – Someone Somewhere May 2 '16 at 19:21
  • @SomeoneSomewhere That is a command line I copied from the referenced solution in text. Removing the sudo doesn't solve the issue. But thank you for your kind reminder :) – Xiaodong Qi May 2 '16 at 21:17
  • Is there any reason for Ubuntu to continue using MS fonts? A much better solution would be to make Ubuntu get rid of those fonts! – jap1968 Dec 14 '16 at 7:08
  • Or, we can push Microsoft to make their fonts open-source :) – Xiaodong Qi Dec 15 '16 at 6:38
  • What incentive would Microsoft have to make their fonts opensource? – simgineer Feb 18 '18 at 15:28
112

Summary:

wget http://ftp.de.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.7_all.deb
sudo apt-get purge ttf-mscorefonts-installer -y
sudo apt install ./ttf-mscorefonts-installer_3.7_all.deb

This seems to be an Ubuntu server problem for now. Below is a temporary workaround to avoid this problem:

Download all the fonts except for wd97vwr32.exe from the sourceforge site using your favorite internet browser. Put all of the exe files in one folder.

Then run the command line in your terminal:

sudo dpkg-reconfigure ttf-mscorefonts-installer

with the fonts folder directed.

Notice that you may need to repeat this operation for a couple of times if there are more missing-fonts messages popping up. For all missing fonts, you should try searching for the missed fonts, download the exe files and put them in the fonts folder created in the previous step and redo the command line until no more error messages pop up.

The prompt will stop popping out after this. As pointed out in the other answer, this is a bug of the Ubuntu 16.04 system, and hopefully it will be fixed at the root soon.

Update on 2018-11-6: A better/easier workaround is to download the 3.7 or the latest version of ttf-mscorefonts-installer from Debian. Double clicking and installing that package with gnome's software center (and probably also ubuntu's software center) works perfectly. Or, if you would like to run some code, here you go:

wget http://ftp.de.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.7_all.deb -P ~/Downloads

will download the package to your Downloads folder, and

sudo apt install ~/Downloads/ttf-mscorefonts-installer_3.7_all.deb
  • 6
    Thanks! The 30 Nov update (using the "code" you provided) seems to have solved this annoying problem for me (16.04 LTS). I tried many other proposed solutions, but this is the only one that worked. – Dɑvïd Dec 9 '16 at 10:10
  • Using the Debian package fixed it for me too on Xubuntu 16.04 LTS. – James McLaughlin Dec 16 '16 at 14:11
  • 1
    Confirming this worked on 16.04 and 16.10. To test I used the normal ttf package and after 3 fail attempts and tested this one. It worked immediately, so, so far this is the only way of installing the ttf package and it's fonts. – Luis Alvarado Dec 24 '16 at 15:14
  • 3
    Thank you, looks like Dec 10 update works for me with just two commands – Nikolay Prokopyev Dec 30 '16 at 10:46
  • Thank you very much for the wget info - downloading and installing the .deb package fixed the problem immediately; in contrast to all the other solutions proposed elsewhere. – GhostCat says Reinstate Monica Jan 10 '17 at 8:32
17

This is a confirmed bug in Xenial Xerus (16.04). Same error persists for me. I tried installing the ms-fonts separately using the command line which also failed. But installing by downloading the packages from the Internet through browser is possible.

For the bug tracking and the solution for the bug can be tracked through the thread link below. The bug is still open and it has not yet been solved.

https://bugs.launchpad.net/ubuntu/+source/aptitude/+bug/1543280

Please report any solutions found for the bug.

UPDATE :

I found a way removing the temp files in the partial folder and installing the fonts through terminal. This worked for me.

sudo dpkg -P ttf-mscorefonts-installer
sudo rm -rf /var/lib/update-notifier/package-data-downloads/partial/*
sudo apt-get --purge --reinstall install ttf-mscorefonts-installer

Please see the link below.

How to make ttf-mscorefonts-installer package download fonts, after it says it installed?

  • For a temp fix, you can download the fonts in a folder and run command: sudo dpkg-reconfigure ttf-mscorefonts-installer – Xiaodong Qi May 5 '16 at 5:01
  • 1
    Just a side note: I reported to the bug you mentioned in your answer, developers have been focusing on the permission issue and such. – Xiaodong Qi May 5 '16 at 5:06
  • 4
    i get: Err:1 http://downloads.sourceforge.net/corefonts/andale32.exe Hash Sum mismatch Fetched 969 B in 1s (904 B/s) W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied) E: Failed to fetch http://downloads.sourceforge.net/mirrorproblem?failedmirror=vorboss.dl.sourceforge.net Hash Sum mismatch E: Download Failed Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ... – marsUbuntux Nov 29 '16 at 9:48
  • Update worked for me a nice simple well explained solution. – RoyC Apr 25 '17 at 14:50
1

The solution I've found is to download Debian's version of this package:

https://packages.debian.org/en/sid/all/ttf-mscorefonts-installer/download

Then the fonts install without any problems! Hooray, and it's sad that Ubuntu failed to create a functional package when they could've just copied Debian's version and had it work!

protected by Community Aug 2 '16 at 8:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.