2

I am trying to install package called phatch - image processing application, it has a bug on 16.04 reported and confirmed, it just won't start. On 15.10 it works great.

Can I install this phatch from 15.10 release's mirror? Is there any way this application can run on 16.04 before the bug is patched?

I tried adding this line to my /etc/apt/sources.list

deb http://de.archive.ubuntu.com/ubuntu wily main universe

I did remove the app and installed it again:

$sudo apt-get update
$sudo apt-get autoremove phatch
$sudo apt-get install phatch

I also tried -t parameter with apt: $sudo apt-get -t wily install phatch no results there.

While trying alternative approaches, it allowed me to install some lower versions of dependencies for phatch that I was not allowed before just from xenial release, but application does not work, errors look the same:

~$ phatch 
/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py:8196: GtkWarning: gtk_disable_setlocale() must be called before gtk_init()
  return _core_.PyApp__BootstrapApp(*args, **kwargs)
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py", line 16765, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "/usr/share/phatch/phatch/pyWx/gui.py", line 1218, in show_frame
    frame = Frame(self.filename, None, -1, ct.TITLE)
  File "/usr/share/phatch/phatch/pyWx/gui.py", line 327, in __init__
    frame.Frame.__init__(self, *args, **keyw)
  File "/usr/share/phatch/phatch/pyWx/wxGlade/frame.py", line 141, in __init__
    self.tree = Tree(self, -1, style=wx.TR_HAS_BUTTONS|wx.TR_NO_LINES|wx.TR_FULL_ROW_HIGHLIGHT|wx.TR_HIDE_ROOT|wx.TR_DEFAULT_STYLE|wx.SUNKEN_BORDER)
  File "/usr/share/phatch/phatch/pyWx/wxGlade/frame.py", line 26, in __init__
    set_dirty   = parent.set_dirty,
  File "/usr/share/phatch/phatch/lib/pyWx/treeEdit.py", line 96, in __init__
    self.CreateImageList(icon_size)
  File "/usr/share/phatch/phatch/lib/pyWx/treeEdit.py", line 111, in CreateImageList
    self._AddFormToImageList(form, icon_size, icon_disabled)
  File "/usr/share/phatch/phatch/lib/pyWx/treeEdit.py", line 120, in _AddFormToImageList
    wx_image = pil_wxImage(wxImage_pil(wx_image).resize(icon_size,\
  File "/usr/share/phatch/phatch/lib/pyWx/wxPil.py", line 46, in wxImage_pil
    image.fromstring(wx_image.GetData())
  File "/usr/lib/python2.7/dist-packages/PIL/Image.py", line 746, in fromstring
    "Please call frombytes() instead.")
Exception: fromstring() has been removed. Please call frombytes() instead.

Both Wily and Xenial installs same version of phatch - 0.2.7.

  • Looks like its about to fail because of wxgtk3.0 – Videonauth May 2 '16 at 16:18
  • On 15.10 it also uses python-wxgtk3.0 and works, it also gives these few lines of errors, but works there, so I ruled the wxgtk3.0 out: /usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py:8196: GtkWarning: gtk_disable_setlocale() must be called before gtk_init() return _core_.PyApp__BootstrapApp(*args, **kwargs), I have also tried installing python-wxgtk2.8 and uninstalling 3.0 with no results. – Mike May 2 '16 at 16:24
  • You could try to download the wily packages as .deb files from here you only would need the to apt-mark hold those packages so they wont get upgraded again. – Videonauth May 2 '16 at 16:28
  • Just tested it. It is giving me the same errors as 16.04, it looks exactly the same version: 0.2.7.1-3.1: all for both 15.10 and 16.04. – Mike May 2 '16 at 16:33
  • Ok then I'm out of clues. – Videonauth May 2 '16 at 16:36
2

I had the same issue after I updated to 16.04 Here I found a fix, which worked for me! https://bugs.launchpad.net/phatch/+bug/1538906/comments/4

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.