8

For the past couple of Ubuntu releases the live CD has always worked fine, however after installation I would always get a blank screen on startup. I could reboot the system by blindly CTRL + ALT + F1 and sudo rebooting, so it's definitely the display/open source drivers.

To counter this, I have always had to boot into safe graphics mode (or add nomodeset, xforcevesa to the grub boot options) then install the proprietary AMD drivers. This solved the issue in the past, however now that Ubuntu 16.04 does not support the proprietary drivers, does anyone know of a way around this issue?

My laptop is a Lenovo Z575 with an AMD A6 APU. Most of the forum posts are not up to date enough for dealing with 16.04.

Any ideas? Thanks

  • 2
    Can you humor me and test something out? I also have an AMD APU with a similar issue (an a4-3400, an old desktop part). I am running Xubuntu 16.04, but this was an upgrade from an existing 15.10 installation. At least on my machine, I have no graphical output once xubuntu boots, and CTRL+ALT+F1 results in no output to the screen either. But, if I blind-login and then lock the screen with CTRL+ALT+L, the screen comes back for unlock! It works normally after that. I have no idea why though. I was considering asking how to actually fix it on here but found your question while doing recon. – neocpp May 6 '16 at 21:10
  • That's interesting, I'll give that a go when I get in tonight and let you know – Daniel Doyle May 9 '16 at 14:57
  • Also, I don't know if this will help anyone else, but I just noticed that this only happens on VGA; everything seems to go smoothly with the DVI output (no lock screen shenanigans required). If you plug in a monitor to your laptop, maybe you can check if the output is being sent there? If that's the case maybe there's a config setting that can be set -- although with xorg.conf gone I don't know where to start looking. – neocpp Jun 4 '16 at 17:56
  • Sorry about the late reply guys, been bogged down with work! I've found a workaround which involves putting my laptop to sleep once the hard drive activity has died down, then resuming and everything works fine from then on. Unfortunately this does not persist between reboots, so still a little stumped. It's obvious now that it's some issue between the open source drivers power management and the A series APU's – Daniel Doyle Jul 24 '16 at 11:53
  • For avoidance of doubt, are you using the amdgpu driver, xserver-xorg-video-amdgpu? I've an A8 and am using the amdgpu-pro drivers, I had problems with lightdm and sddm, purging the former and reinstalling the later seemed to do the trick. – pbhj Aug 11 '16 at 12:24
4

You may try adding nomodeset quiet splash to

/etc/default/grub

I found that this worked, although I also had to specify the default resolution of my laptop GRUB_GFXMODE=1920x1080 to get it to work satisfactorily. Remember to sudo update-grub to get it to work on every boot.

There was also a post about the difficulties in using the AMD driver and 16.04

I am using a HP Pavilion based AMD-APU on 64bit 16.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.