13

I have a recently built PC with Z170 mobo and 6700k/980Ti and a Corsair Strafe (backlit) keyboard. I had some issues with the Ethernet interface not appearing anywhere, which I solved like other people with the same specs on Ubuntu 14.04.

After I boot on Ubuntu, it takes 2-3 minutes for the keyboard to start responding. Also, if I try to adjust its brightness, it will stop responding again. I have no idea where to start looking, since I can't find similar problems online. I have a 750 Watt supply, so I don't think it has to do with high power needs.

Note: The problem with the keyboard existed from the beginning..along with the ethernet thing

UPDATE: I bought a Razer Deathadder and it also takes the same amount of time to start working on boot.

  • To enhance this question a bit, the keyboard is a USB interface, and here is the product page for it: corsair.com/en-us/… – Strozykowski May 11 '16 at 14:43
  • 1
    Which Kernel version do you currently use? (uname -r) If it's lower than 4.4 you could try to boot a 16.04 live CD/DVD/USB-stick and see if it works there. Does dmesg | tail show anything related to USB/keyboard or so after the keyboard starts responding? (dmesg shows the kernel messages and is usually a good place to start looking :-) ) – Kai May 11 '16 at 16:28
  • kernel: 4.2.0-35-generic; and in this pastebin is the result of 'dmesg | tail' pastebin.com/AaXgBbfi Also, I remember trying out 16.04 before and had the same issue. Thanks :D – kalfasyan May 11 '16 at 16:43
  • In addition to the dmesg output, I'd suggest trying a less fancy keyboard, a stock $10 would do - there may be something making the keyboard's firmware itself take time to start up. – salmonmoose May 12 '16 at 4:50
2

If you can reproduce the issue with another keyboard there may be another device that is causing the issue. Some good troubleshooting steps if you haven't already tried them:

  • Try a live boot CD/DVD to see if the issue still occurs when booting into another OS (or a generic Ubuntu install)
  • Unplug everything external except power, primary display, and the keyboard. This includes any USB dongles for wireless devices. Reboot and see if it still happens.
  • Also try unplugging any internal USB headers such as front facing ports or control panels.
  • Nuclear option is to start removing PCIe add-on cards.

If it is a software/driver issue it should start working after the first step. If it is a hardware issue you'll have to keep digging to find the cause.

  • Ok, I am not sure what worked exactly but now it only takes 2-3 seconds to start which is perfectly fine. I turned off my PC, removed all USBs, removed all other plugs from the multi-socket, apart from my PC and monitor and left it for a few seconds. After booting, it was fine (even with everything else plugged in again). – kalfasyan May 12 '16 at 6:40
  • 1
    USB has to negotiate speed, power, and a bunch of other stuff when they connect. Also they share the bus, so one device sending bad data can cause strange things to occur with other devices. Plug them in one at a time and test each time and you may find which one is causing issues. – Greg Bray May 12 '16 at 6:45
  • Could also just be a bad USB port, so always worth trying a different port. – Greg Bray May 12 '16 at 6:46
  • Ok, we have to mention this solution because it played a role for eliminating the delay for good. In the last command I used 'update-initramfs -u' instead. Thank you Greg for your time and interest. I hope others can solve their similar problem now – kalfasyan May 12 '16 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.