I just installed Ubuntu 16.04 LTS along with the packages php, mariadb and nginx. I ran mysql_secure_installation and changed the root password.

Now when I try to login to mysql using the root account while logged in Ubuntu as normal user account I get access denied.

When I login using sudo mysql, mysql doesn't even ask me password. If I run mysql_secure_installtion I see that old settings never got set permanently.

What am I doing wrong?

  • If you'd like to get back to the default password less root access via the unix_socket plugin: sql UPDATE mysql.user SET plugin='unix_socket' WHERE user='root'; flush privileges – Wolfgang Fahl Sep 29 at 5:44

10 Answers 10


I recently upgrade my Ubuntu 15.04 to 16.04 and this has worked for me:

  1. First, connect in sudo mysql

    sudo mysql -u root
  2. Check your accounts present in your db

    SELECT User,Host FROM mysql.user;
    | User             | Host      |
    | admin            | localhost |
    | debian-sys-maint | localhost |
    | magento_user     | localhost |
    | mysql.sys        | localhost |
    | root             | localhost |
  3. Delete current root@localhost account

    mysql> DROP USER 'root'@'localhost';
    Query OK, 0 rows affected (0,00 sec)
  4. Recreate your user

    mysql> CREATE USER 'root'@'%' IDENTIFIED BY '';
    Query OK, 0 rows affected (0,00 sec)
  5. Give permissions to your user (don't forget to flush privileges)

    Query OK, 0 rows affected (0,00 sec)
    Query OK, 0 rows affected (0,01 sec)
  6. Exit MySQL and try to reconnect without sudo.

I hope this will help someone :)

| improve this answer | |
  • 16
    This was the only thing that worked for me, does somebody knows exactly what happened with the root user when you install mysql-server on 16.04? – Ruggi Aug 18 '16 at 17:45
  • 40
    Hold it, Doesn't % mean you can connect from anywhere...remotely? – stephen Nov 4 '16 at 8:01
  • 11
    You can change row to: CREATE USER 'root'@'localhost' IDENTIFIED BY ''; – vladnev Dec 5 '16 at 8:36
  • 13
    To the security-concerned: the unsecured root@localhost mysql connection pattern is a bread-and-butter staple of local development but should appear absolutely nowhere else. – Charney Kaye Jan 11 '17 at 20:31
  • 5
    The grant statement for the new root user here does not give "with grant" to root so root can't grant without running this afterwards: dba.stackexchange.com/a/62046/115679 Please change the grant statement to grant all privileges on *.* to 'root'@'localhost' with grant option; – Loren Apr 4 '17 at 14:17

If you install 5.7 and don’t provide a password to the root user, it will use the auth_socket plugin. That plugin doesn’t care and doesn’t need a password. It just checks if the user is connecting using a UNIX socket and then compares the username.

Taken from Change User Password in MySQL 5.7 With "plugin: auth_socket"

So in order to to change the plugin back to mysql_native_password:

  1. Login with sudo:

    sudo mysql -u root
  2. Change the plugin and set a password with a single command:

    ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'test';

Of course you can also use the command above to set an empty password.

Just for the record, (and MariaDB < 10.2 users) there is also another way to only change the plugin without providing a password (leaving it empty):

update mysql.user set plugin = 'mysql_native_password' where User='root';
// to change the password too (credits goes to Pothi Kalimuthu)
// UPDATE mysql.user SET plugin = 'mysql_native_password', Password = PASSWORD('secret') WHERE User = 'root';
| improve this answer | |
  • 2
    Thanks, for some reason this got set automatically suddenly after an apt-get upgrade I think... – Tominator Oct 28 '16 at 9:32
  • 4
    Also, I like this answer more - it's a lot less destructive ;-) – benzkji Jan 30 '17 at 11:27
  • 4
    For MariaDB < 10.2, to change plugin along with the password, here's the query: UPDATE mysql.user SET plugin = 'mysql_native_password', Password = PASSWORD('secret') WHERE User = 'root'; FLUSH PRIVILEGES; Source: stackoverflow.com/a/41537019/1004587 – Pothi Kalimuthu Jul 11 '17 at 11:12
  • 6
    This should be the accepted answer – Geo C. Nov 17 '17 at 12:48
  • 3
    I wish I could vote this up twice. – James Smith Mar 22 '18 at 16:10

In short, on MariaDB

UPDATE mysql.user SET plugin = 'mysql_native_password', 
      Password = PASSWORD('NEWPASSWORD') WHERE User = 'root';

where you replace NEWPASSWORD with the password you want, and everything else verbatim.

The issue here is that when MariaDB or MySQL are installed/updated (especially if at some point root is set without a password) then in the Users table the password is actually empty (or ignored), and logging in depends on the system user corresponding to a MySQL user. You can test this as follows by switching to system root, and then type:

mysql -uroot -p

Then enter either no password or the wrong password. You'll probably be let in. (You may even be able to log in from the unix root by simply # mysql as the password is irrelevant and the user is defined).

So what's happening? Well, if you log in as root and do the following:

select User,host,plugin from mysql.user; 
| User           | host      | plugin                |
| root           | localhost | auth_socket           |

you'll note auth_socket (which may read unix_socket on MariaDB). These sockets ignore passwords and allow the corresponding Unix user in without a password check. This is why you can log in with root but not with a different user.

So the solution is to update the Users to not use the auth_socket/unix_socket and properly set a password.

On MariaDB (<10.2, see comments below) which is on the Ubuntu version 16 as of 2017 this should suffice. NEWPASSWORD is your password. mysql_native_password you type verbatim.

UPDATE mysql.user SET plugin = 'mysql_native_password', Password = PASSWORD('NEWPASSWORD') WHERE User = 'root';

(It's possible that setting the plugin to empty would work. YMMV. I didn't try this. So this is an alternative.)

UPDATE mysql.user SET plugin = '', Password = PASSWORD('NEWPASSWORD') WHERE User = 'root';


ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'NEWPASSWORD';



For the record, the solution involving deleting the user and recreating it with '%' got me totally locked out of the database, and can cause other problems unless you get the grant statement exactly right - easier to simply update the root you already have.

In my experience, the issue only happens with the root user, as other users will be added manually not part of an initial install/update.

| improve this answer | |
  • 2
    Found this to work perfectly. Makes me wonder though why changing the root password with mysql_secure_installation didn't have the same effect. Where does it store the new password? – Mausy5043 Jul 28 '18 at 10:14
  • Can you edit your answer and say more about each of the commands as you go? I'm not clear on which are applicable. Is it the two UPDATEs that apply to MariaDB <10.2 and the ALTER to other versions? And is the second UPDATE an alternative to the first, or do we need to type both? Finally, is 'mysql_native_password' something to type verbatim, or should we replace it with our intended root password for MySQL? – Michael Scheper Dec 17 '18 at 2:23
  • 1
    @MichaelScheper It's a while back so I don't want to edit too much, but here's what I remember. (1) Do the first UPDATE only (<10.2 may not be a requirement). (2) Yes, type 'mysql_native_password' verbatim. Essentially, what you are doing is telling mariadb: "Don't use Unix priveleges, use the database priveleges". The mysql_native_password is that option. – Gazzer Dec 17 '18 at 4:26
  • Damn I spelt 'privilege' wrong! – Gazzer Dec 17 '18 at 4:32
  • 1
    Looks like you only missed the edit time limit by 1½ minutes, too! I get frustrated by that sometimes, too. Anyhow, thanks! – Michael Scheper Dec 21 '18 at 2:01

By default, root user is set to authenticate through an auth_socket rather than with a password.

In order to use the password authentication, do:

  1. Login to MySQL root shell:

    sudo mysql
  2. Check authentication methods enabled for different users (optional)

    SELECT * FROM mysql.user;
  3. Make root to authenticate with a password:

    ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'your_password_here';
  4. Flush privileges for the changes to take effect;

  5. Exit and authenticate with your password

     mysql -u root -p 
| improve this answer | |
  • When I did this, I couldn't sudo mysql as root anymore. I had to su first, and then could log into mysql as root. So I changed it back to auth_socket. – untill Jan 22 '18 at 14:17
  • Single command: mysql -u root -p -e "use mysql;update user set plugin='mysql_native_password' where user='root';flush privileges;" – Chris Stryczynski Jul 23 '18 at 18:43
  • If you want to lose access to your MySQL instance, then this answer is the easy way. – Danila Vershinin Aug 22 '19 at 8:56
  • Yes. This worsened the problem. – Guissmo May 30 at 13:18

Try to create new mysql account, for me it has worked (mysql 5.7.12):

  1. Login as sudo:

    sudo mysql -uroot
  2. Create new user and grant him privileges (no password):

    CREATE USER 'admin'@'localhost' IDENTIFIED BY '';
    GRANT ALL PRIVILEGES ON *.* TO 'admin'@'localhost';
  3. Login as new user:

    mysql -uadmin
| improve this answer | |

If you just run mysql command under root user you will be granted access without asked for password, because socket authentication enabled for root@localhost. .

The only way to set password is to switch to native authentication like:

$ sudo mysql

mysql> ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'test';

| improve this answer | |

I had to do two things (thanks to @Todor and @Loremhipsum):

update mysql.user set plugin = 'mysql_native_password' where User='root';
grant all privileges on *.* to 'root'@'localhost';

and then:


I would not recommend to drop user root.

| improve this answer | |

Try this code first,

echo "CREATE USER 'root'@'localhost' IDENTIFIED BY 'root';" > your_init_file.sql
echo "GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' WITH GRANT OPTION;" >> your_init_file.sql 
echo "FLUSH PRIVILEGES;" >> your_init_file.sql

and then,

killall mysqld
mysqld_safe --init-file=$PWD/your_init_file.sql

then press Ctrl+Z and type: bg to run the process from the foreground into the background, then verify your access by:

mysql -u root -proot
mysql> show grants;
| improve this answer | |

I’ve been adapting some provisioning scripts I have created to use MariaDB and ran into this exact issue. Piecing together lots of info here an Gazzer’s answer really zeros in in the issue; it all boils down to the auth_socket/unix_socket setting.

So when using MariaDB 5.5 (under Ubuntu 14.04) and MariaDB 10 under (Ubuntu 16.04), logging into MySQL and running this command cleared things up right away:

UPDATE mysql.user SET plugin='' WHERE User='root';

The other answers—including the highest voted answer as of this post by Loremhipsum—really encourage bad practices by recommending dropping a user and then recreating them. To me, that is a pretty radical solution. The best/simplest solution os to nullify the plugin value, flush privileges and get on with life.

| improve this answer | |

I had the same issue and running the following fixed it:

mysql_upgrade --force
| improve this answer | |
  • Sadly that didn't work. I am reinstalling ubuntu. – codescope May 3 '16 at 9:58
  • 1
    I just did fresh install of ubuntu 16.04 and installed mariad-server. After installing I ran mysql_secure_installation and set password. After going through rest of the steps in mysql_secure_installation, I ran it again and it looks like it is not saving the changes. I still can't login from my normal user account. Could it be a bug? – codescope May 3 '16 at 11:45
  • This will never help. The issue has nothing do with the actual install of the MariaDB binary but rather the user root being set with plugin settings that are non-standard. The only edge case where an upgrade of the DB might help in a case like this is if the mysql_upgrade process itself accounts for the plugin setting which I doubt. – Giacomo1968 Oct 20 '17 at 1:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.