0

I've just created a Unity Scope project in Ubuntu SDK. However I'm not able to run it, If I target the Desktop, I have the following error :

Starting /usr/ubuntu-sdk-ide/share/qtcreator/ubuntu/scripts/qtc_desktop_scoperunner.py...
ScopeRunner> Setting up environment
ScopeRunner> TmpDir:      /home/bertrand/.local/share/unity-scopes/unconfined/stars.kramp/
ScopeRunner> AppId:       stars.kramp_stars
Debug-helper> Environment initialized, starting the application
Debug-helper> Executing /usr/bin/unity-scope-tool /home/bertrand/dev/uapp/build-stars-Desktop-Default/src/stars.kramp_stars.ini
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Reinstalling the application may fix this problem.
The program has unexpectedly finished.

My desktop kit configuration is below : enter image description here

And I've also tried on with an emulator target, then I've another error :

Results:
Fatal error: /tmp/stars.kramp_0.1_armhf.click failed to install.
WARNING:root:Signature check failed, but installing anyway as requested
Cannot install /tmp/stars.kramp_0.1_armhf.click: Framework "ubuntu-sdk-15.04.4" not present on system (use --force-missing-framework option to override)

Sdk-Launcher> Installing the application failed

My armhf kit configuration is below : enter image description here

I'm new to QT/UbuntuPhone/Click/Kit/Framework/target/andSoOn development environment, so I'd like to understand what's wrong.

I'm under ubuntu 15.10.

0

I am able to run on the Desktop target now. I've installed qt5-defaul and then configured the QT version in the Desktop target.

Not tried with the emulator but the Desktop is sufficient to develop

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.