3

I get the following error during exporting the image to Imgur Guest or ImmIO Guest. (Throws same error for all Guest upload servers)

Error while connecting

malformed JSON string, neither array, object, number, string or atom, at character offset 0 (before "(end of string)") at /usr/share/shutter/resources/system/upload_plugins/upload/Minus.pm line 145.

Please see the screen shot below enter image description here

  • This really is a bug report. I'm happy there's a listed workaround below, but I'd like to see this cross referenced with a bug so we can correct the ubuntu packaging. – lazyPower Sep 15 '16 at 20:04
3

Wintermute seems to be right, it's just broken (as of now). However, in the link he provided, there seems to be a patch.

What you need to do is download the "Imgur.patch" file, and put it next to "Imgur.pm" found in:

/usr/share/shutter/resources/system/upload_plugins/upload/

Then go to that directory in your terminal, then run

sudo patch Imgur.pm Imgur.patch

This should use the .patch file to patch Imgur.pm. If it goes over well, the console should just output "patching file Imgur.pm" and nothing else.

|improve this answer|||||
  • This worked, Thanks. $ sudo patch Imgur.pm ~/Imgur.patch patching file Imgur.pm patch unexpectedly ends in middle of line Hunk #3 succeeded at 101 with fuzz 1. – Mani Deep Sep 16 '16 at 5:31
3

Imgur guest upload is currently broken. You can use alternatives like Imgur-Screenshot until it's fixed.

|improve this answer|||||
  • 1
    not only imgur, other guest sites are also throwing same error. – Mani Deep May 2 '16 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.