New to Ubuntu, and recently updated to 16.04 (yes, yes, I probably should have waited being new and all).

Generally it's working well...but I'm having some update problems. The dreaded red triangle in the upper righthand corner. I've tried doing some searching on my own, but to no avail. When I tried updating through the software update, I get the following notice.

W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1), 
W: There is no public key available for the following key IDs:
W: The repository 'http://ppa.launchpad.net/conscioususer/polly-daily/ubuntu xenial Release' does not have a Release file,
W: Data from such a repository can't be authenticated and is therefore potentially dangerous to use., 
W: See apt-secure(8) manpage for repository creation and user configuration details., 
E: Failed to fetch http://ppa.launchpad.net/conscioususer/polly-daily/ubuntu/dists/xenial/main/source/Sources  404  Not Found, 
E: Failed to fetch http:// ppa.launchpad.net/conscioususer/polly-daily/ubuntu/dists/xenial/main/binary-amd64/Packages  404  Not Found, 
E: Failed to fetch http:// ppa.launchpad.net/conscioususer/polly-daily/ubuntu/dists/xenial/main/binary-i386/Packages  404  Not Found, 
E: Some index files failed to download. They have been ignored, or old ones used instead.

Now, I'm not an idiot, and have checked around to see if I could find the problem myself, but nothing seems to be posted for this problem in 16.04. Can anyone help?


3 Answers 3


Basically you have a lot of sources that don't have proper keys anymore .. you will need to either remove these sources or get new keys for them.

Go to Start--settings--Software & Updates and click on the Other Software tab

then find the things on that list that say there is no key or 404 not found and uncheck them ... once done close the window and it will ask you to reload ... it should reload without errors .. if there are still errors .. you may need to remove more sources


your issue is related with custom PPA sources you most likely added before the update to 16.04.

Usually ppa's get disabled while the update process and the user has to take care about them afterwards.

A possible solution is disabling those ppa's manually in the first place via "Software & Updates" aka "software-properties-gtk" in the "Other Software" tab.

Then close the "Software & Updates" UI and your system should re-scan and check the available sources.

At that point check for each single PPA which you are using

  • do i still need them & do i trust them
  • if they are offering an updated ppa for 16.04 and then
  • re-add them step by step.

first goto this directory: cd /etc/apt/sources.list.d/

and then remove the file associated with google chrome: sudo rm google-chrome.list

This will definitely work. Keep smiling, If in this directory there are another files that associated with other applications that you removed already then remove them also.

  • This does not answer the question. Your workaround merely deletes the repository leaving the installed browser without future updates. May 4, 2016 at 22:50

Not the answer you're looking for? Browse other questions tagged .