0

This is my situation:

  1. I had in my hard drive two operating systems: Windows 8.1 and Ubuntu 12.04 LTS Precise Pangolin.

  2. Using a bootable USB stick, I created another partition to install in it the newer Ubuntu MATE 16.04 LTS Xenial Xerus (the operating system in the bootable USB stick).

  3. After creating the partition and trying to install Ubuntu MATE 16.04 LTS Xenial Xerus in it, I got some error messages that I cant remember right now. The result was that I couldn`t boot my computer anymore and, when booting my machine, I was sent to a black screen with the words "grub rescue" on it.

  4. Then, I decided to completely erase my entire hard disk and install Ubuntu 12.04 LTS Precise Pangoling in it once again. I used a bootable USB stick with Precise in it and used the entire hard disk in the install.

  5. The install was running smooth and by the numbers until I got this message in the end:

grub-efi-amd64-signed failed to install into /target/. Without GRUB boot loader, the installed system will not boot

  1. I ran boot repair and got no solutions at all. Only a black screen with the words grub rescue on it.

  2. I asked boot repair to create a report (http://paste.ubuntu.com/16184588/) about the boot conditions in my machine. I don`t know how to read that report. Sorry for that. :-)

  3. My hard disk partitions are this way right now:

Partition File-System Size Used Unused Flags

/dev/sda1 fat-32 94.00-MiB 1.46-MiB 92.54-MiB boot

/dev/sda2 ext4 927.48-MiB 17.75-GiB 909.73-GiB

/dev/sda3 (key image) linux-swap 3.94-GiB

StackOverflow doesn`t support tables. Sorry for the mess above.

Some additional informations:

I think something went wrong when trying to configure UEFI, Secure Boot, Fast Boot and all those stuffs of "modern" computer systems. The BIOS was so easy to use. The fact is that I did something wrong, since my computer is a useless pile of metal right now. I cant boot it and I cant install anything in it.

By the way, all I want right now is to install Ubuntu 12.04 LTS Precise Pangoling in my computer. I have a bootable USB stick with it and I don`t mind using the entire hard disk for that.

Best regards.

3
  • Sorry to say I'm not real familiar with UEFI with Ubuntu... my server is running an older system so I haven't ran into UEFI yet ... I do know that 12.04 is very old and it could be possible it just isn't compatible with a UEFI boot. Have you tried to install 16.04 LTS on it. Formatting the sda2 partition first... since you said you don't care about the data .. it looks like sda1 is the EFI partition .. sda2 is your 12.04 install and sda3 is your swap – John Orion May 2 '16 at 4:59
  • as i understand it and I may be wrong here but ... I think 12.04 is installing grub on sda2 because it cant install it on the UEFI partition and the computer being UEFI is looking for the boot information in the EFI partition to boot – John Orion May 2 '16 at 5:07
  • Thank you for your reply. The reason Im not willing to install Ubuntu 16.04 is that it cant configure my DSL Internet connection (pppoeconf is not present in that distribution and it uses pppoediscovery, which doesnt configure my connection at all). Concerning Ubuntu 12.04 LTS UEFI capabilites, well Im running it right now from a bootable USB stick and the only way of doing that in this machine it to select the "UEFI" option on the boot menu. I dont know if that`s sufficient to say Ubuntu 12.04 LTS supports UEFI. – Marcelo Augusto May 2 '16 at 7:59
0

Here are my observations:

  • Your EFI System Partition (ESP) is small -- 94 MiB. In theory, this should be OK, but in practice, it might not be, particularly with an older (early 2010s) computer -- some early EFIs have somewhat flaky FAT drivers that don't cope well with sub-512 MiB FAT filesystems. Thus, you could try increasing the size of your ESP. I recommend 550 MiB because that's enough above various limits to avoid problems that can occur if you try creating something that's exactly 512 MiB.
  • There's no evidence of a boot loader installed on the ESP. This could be a bug in Boot Repair, but given the errors you describe, it's probably the case that there really is no boot loader there. Unfortunately, there's no clue in what you've reported about why the boot loader could not be installed; all I can do is speculate about flaky FAT drivers.
  • A less radical solution is to install another EFI boot loader. Most of these are at least a little tricky to install manually, but you could install my own rEFInd without too much difficulty:
    1. Download the USB flash drive or CD-R version of rEFInd from the links on its downloads page.
    2. Prepare a boot medium from the file you download.
    3. Boot with the rEFInd medium. With luck, it will a boot option for Ubuntu, which I expect is installed except for GRUB.
    4. Boot Ubuntu.
    5. Install rEFInd using the Debian package or PPA.
    6. Reboot. If it works, great. If not, perhaps the rEFInd installation will have at least produced a more helpful error message.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.