2

My microphone is not working in Mac bookpro 17(2010) after ubuntu 15.10 to 16.04.

Sound settings Input shows microphone build-in Audio. but no input level signal.

BTW, my Mac bookpro 13(2009)'s build-in microphone is working in Ubuntu 16.04.

How to fix it? please help me.

1

With my old macbook 2,1 (Libreboot + Elementary OS Loki (based on Ubuntu 16.04)) the solution to getting the microphone working was installing pavucontrol and on the Input Devices tab choosing Microphone (unplugged) instead of Line In (plugged in). In fact I have nothing plugged in or unplugged.

  • Working solution for Ubuntu 18.04.1 LTS on Macbook Pro 17" Early 2011. Thanks! – Pascal Oct 29 '18 at 9:37
0

I have a MacBook Pro Core i5 2.5 13" Retina 2012 and was in the same position, sound worked fine but no microphone.

Adding the following line to the bottom of /etc/modprobe.d/alsa-base.conf worked for me:

options snd-hda-intel model=mbp101

as per Microphone not working on Ubuntu 14.04 on MacBookPro10,2

I think I had done this in the past but a clean install of Xenial had removed the line, perhaps the same happened when you upgraded?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.