1

I have just reinstalled the Ubuntu 14.04 on my laptop due to upgrading to an SSD and now I am experiencing an issue with nvidia drivers. When I install a proprietary driver after a reboot the systel launches (i can hear sound) but the screen is black. I have tried several guides and no luck so far.

I have tried installing both availiable drivers from nvidia:
nvidia-352
nvidia-352-updates

The solution proposed it the following answer didn't help:
Proprietary NVidia drivers with EFI on Mac, to prevent overheating

Laptop ASUS K501LB
VGA GeForce 940M

UPDATE: The nvidia-352 driver is working fine, but only after I have reinstalled Ubuntu 14.04. This time I used 14.04.3 and the problems were when I was using 14.04.4.

P.S. Should I report this as a bug to Ubuntu developers?

0

You may have installed a bugged driver. I know on some GPU models, there are 3 to four different proprietary drivers to install. Which results in the black screen of Death. Similar to the black screen of death on Windows where a buggy windows update or an infection "deletes" access to the desktop.

From Nixie Pixel on YouTube, she was able to do a work around. This video is from a while ago and she is using 12.04, however, it should work for 14.04.

YouTube Video

  • Thank you for your advice. After following the instructions from that video I have managed to get an image of the login screen, but it is in a very low resolution and I can't log in - when I enter my password I am still ending up seeing the login screen and asked to enter the password to log in. – spektro37 May 2 '16 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.