9

I have a media computer which I recently reformatted to Ubuntu 10.04. I am probably just missing something obvious but I can't figure out how to share folders and files, so that I can browse to them on my Windows computers in order to copy files to/from the computer.

How do I do this?

6

Right-click a folder and select "Sharing Options". Then check off "Share this folder".

  • 4
    Make sure samba is installed first. I don't think it is on default installs. – jfoucher Aug 4 '10 at 5:28
  • @jfo: Ah, yes. Good catch. – Nathan Osman Aug 4 '10 at 5:51
  • 1
    When you check "Share this folder" Ubuntu will offer to install samba by itself. The "catch" in older versions was that you must add a samba password for your use by hand (I mean terminal). I don't know if this is still true for Lucid (10.04) – Javier Rivera Aug 4 '10 at 7:12
2

You've to right-click folder, Sharing Options, check Share this folder and mark the two options related with guest-acess and allowing of file management operations. Then click Create Share

In Windows, just go to Start Menu > Network > YourUbuntuComputer > YourSharedFolder. If your Ubuntu computer isn't showing there, try Super Key (or Windows Key) + R, and write \\ComputerInternalIP or \\YourComputerHostname.

0

If you are trying to share hard drives on a network, you need to go to /media and find the drives, right click on the drive you want to share and select "sharing options" as above. That way you can share the drive across your network.

Dick Smith

0

Get an update first by typing sudo apt-get update and then install samba by typing sudo apt-get install samba then go over to the folder that you want to share and right click it and select sharing options, u should be able to to share access the files now if you network is running.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.