85

I am using chrome Version 50.0.2661.94 (64-bit) and ubuntu 16.04. Most of the time chrome get stuck and hangs whole system.

Does anyone face the same issue?

10
  • 2
    Do you have at least 4GB of RAM? If not, do not use Chrome.
    – dadexix86
    May 1, 2016 at 17:03
  • @dadexix86 I have 4GB RAM May 1, 2016 at 17:06
  • 2
    I am seeing this as well, doesn't appear to be bogging down CPU or RAM so not sure why
    – jdwiegman
    May 3, 2016 at 0:00
  • 1
    On my old laptop with 4GB of RAM, Firefox runs quite a bit faster than Chrome does (chrome is almost unusably slow)
    – user533208
    May 3, 2016 at 13:19
  • @NickWeinberg I noticed the same thing May 3, 2016 at 16:04

5 Answers 5

88

Yeah, I faced the same issue. After a long struggle I solved it.
It's to do with the high memory(RAM) usage by Chrome.

  1. Disable hardware acceleration in chrome settings

    Steps:

    • Type "chrome://settings" in the URL bar, and then click "Advanced"
    • Untick "use hardware acceleration when available"

enter image description here

  1. Disable GPU Rasterization

    • Go to "chrome://flags"
    • Disable "GPU Rasterization"

      enter image description here

  2. Check how Chrome uses memory (Shift + Escape) (OPTIONAL)
    Extensions uses more memory too. If you find high memory usage in extensions (Adblockers are memory hogs), remove them too. That would help.

These would reduce the memory usage significantly.

11
  • 2
    For me "Disable hardware acceleration" and "Disable GPU Rasterization" resolved the problem.
    – rmuller
    Jan 7, 2018 at 19:02
  • 9
    This is not a solution, just a workaround. By disabling hardware acceleration, tasks like video reproduction will rely solely on the CPU. Hardware acceleration should just work. Mar 19, 2018 at 22:09
  • 2
    Didn't help me. Chrome still freezes from time to time on Ubuntu 18.10
    – Peter
    Jan 6, 2019 at 1:27
  • 1
    @TomBoutell It's not buggy harware acceleration. Hardware acceleration offloads some of the CPU work to other hardware (i.e. the GPU). So that the CPU utilisation is low, but in turn this takes up more memory, resulting in poor performance in your case of a 4GB RAM. So disabling Harware acceleration gives all the task to the CPU so you will have more memory to work with.
    – Nusry
    May 18, 2020 at 1:46
  • 2
    oh thx, it was killing me. this works for Ubuntu 18.04 on VirtualBox too
    – aiternal
    Jun 16, 2020 at 11:40
23

How about disabling GPU hardware acceleration ?

If you run Chrome with "--disable-gpu" from within a terminal :

google-chrome --disable-gpu

Did you try that trick ?

If it runs ok, you may then persist that behavior by going to Chrome's settings / "System", uncheck the "use hardware acceleration when available", and restart afterwards.

4
  • I'm having a similar issue (some sites hang, ie gmail). I unchecked "Use hardware acceleration when available" in settings, but I still see freezes. Nov 7, 2016 at 13:12
  • 2
    Didn't help or may not be the solution
    – L.K.
    Sep 6, 2017 at 8:46
  • I experienced the best performance / stability improvement from this. Mar 5, 2018 at 5:23
  • This works. I have dual 4k screens, 4 CPUs and integrated HD530 graphics, and it goes from frequently unusable, to choppier but usable. Can anyone explain WHY though? Where's the bottleneck?
    – stevesliva
    Mar 13, 2018 at 18:01
10

I have a Nvidia GPU and I use version 16.04 stable. Before I have irreversible freezes about every 3-4 hours, even without using Chrome. After I installed the Nvidia 358.16 drivers, everything seems to go ok.

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-358 nvidia-settings
3

It was the same here yesterday, when I added a swap partition and the problem was gone. I don't want a swap partition but what the heck I guess I will just have to get over those 8gigs of drive space :)

5
  • You not necessarily need the equivalent of your RAM as a swap partition, usually in the case you need one 1 Gig should be enough for almost anything.
    – Videonauth
    Dec 20, 2016 at 15:29
  • i have no idea why this would've worked, but after trying all other solutions on Ubuntu 17.04, this was the one that did it.
    – Brandon
    Apr 17, 2017 at 19:03
  • Upgraded to 17.04 (from 16.10 and 16.04) on NTB with SSD and 16G of mem, added swap and will see if it will fix the frezes... not a best solution for SSD though... :-
    – LetynSOFT
    Apr 30, 2017 at 21:08
  • vote me up if it worked for you @Brandon May 7, 2017 at 10:15
  • @LetynSOFT offtopic, but SSDs have improved a lot on durability since the firsts units. If you google a bit, there is a test done by Google themselves on their data centers that found out that they have to replace HDDs more frenquently than SSDs for the same load of transactions. So you shouldn't concern about that. Mar 19, 2018 at 22:15
0

For Ubuntu 20.04, if after opening Gmail Chrome freezes totally, it may be due to dark mode.

DISABLE DARK MODE

or

google-chrome --disable-gpu

Not the answer you're looking for? Browse other questions tagged or ask your own question.