2

Sorry, another novice to Linux systems, but became tired of Windows. I am running Ubuntu 15.10 on a PC. Any time I plug in a USB key it defaults to read only and I am unable to copy anything to it. I have tried various formats, the latest one is Mac OSX Extanded (Journaled), with full permissions.

I have tried finding the answer in the Q&A's and have been playing with the terminal literally for hours, trying one solution after another from the 'Questions that may already have your answer' with no positive result.

This is the line from mount which relates to my USB stick.

*/dev/sdf1 on /media/guy/SanDisk 16 GB1 type hfsplus (ro,nosuid,nodev,relatime,umask=22,uid=0,gid=0,nls=utf8,uhelper=udisks2)*

I have tried unmounting via terminal and then using

sudo mount -t hfsplus /dev/sdf1 /media/guy/SanDisk 16 GB1 -o rw,users,umask=0

And I have also tried the same command without 'GB1' and then again without the '16 GB1'.

I also tried the solution using the chmod command as found in one answer.

Is there an incurable bug in 15.10? New I am, but this should not be so difficult.

Thanks for any help.

P.S. I can reformat the USB keys on another machine to various different types.

0

If it's a MicroSD card and you are using it with an adapter just check and make sure if the lock is not on . If the lock is on then disable it by sliding the switch to the upside(it may be in the different direction depending upon your adapter).

  • Thanks for your input Rishi, but it's a simple 16GB USB stick, not a MicroSD card. – GTrud May 1 '16 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.