6

I have a dual-boot machine with Windows and Xubuntu 16.04. Because of Windows, the hardware clock is set to local time, so I had to use timedatectl to make Xubuntu aware of that after the upgrade to 16.04. The problem is that either I am not able to enable network time synchronization, or timedatectl is giving me wrong output.

systemctl list-units | grep time seems to indicate that the network time service is running:

systemd-timesyncd.service
    loaded active running   Network Time Synchronization 
time-sync.target
    loaded active active    System Time Synchronized

At the same time, timedatectl returns this:

Network time on: yes
NTP synchronized: no
RTC in local TZ: no

Despite what the documentation says, sudo timedatectl set-ntp true has no effect. Any ideas?

1
  • Is this the complete output of timedatectl? I get the current time as well. ntp: no just tells you that you didn't install ntp.
    – guntbert
    Commented May 5, 2016 at 19:52

2 Answers 2

0

Not sure if this is a bug with 16.04. I had the same problem and simply installing ntp helped.

sudo apt install ntp

After a reboot timedatectl showed ntp sync enabled.

0

It seems to be a conflict with ntpdate being on the machine as well. If you ONLY install ntp but not ntpdate, then ntp is allowed to work. With both on the machine, ntp won't stay up on next reboot.

Seems related to this bug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .