4

When I run sudo apt update on my Ubunutu 16.04 LTS Server with MAAS installed I get the following error message:

graeme@MAAS:~$ sudo apt update
Hit:1 http://gb.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://security.ubuntu.com/ubuntu xenial-security InRelease
Ign:3 http://ppa.launchpad.net/maas/stable/ubuntu xenial InRelease
Hit:4 http://gb.archive.ubuntu.com/ubuntu xenial-updates InRelease
Err:5 http://ppa.launchpad.net/maas/stable/ubuntu xenial Release
  404  Not Found
Hit:6 http://gb.archive.ubuntu.com/ubuntu xenial-backports InRelease
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/maas/stable/ubuntu xenial Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Is this something I should ignore or try and fix?

10

Turns out there isn't a stable release of MAAS for Xenial which means I need to be on the ppa:maas/next repository instead of ppa:maas/stable. The issue was brought about after stepping through the MAAS getting started guide which wanted asked me to ad the ppa:maas/stable repository. After removing it with

sudo add-apt-repository --remove ppa:maas/stable

The update went without any errors.

1
  • Did you also use sudo add-apt-repository ppa:maas/next or just remove the old repo?
    – Addem
    Jan 1 '17 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.