0

Compared to the getty tty's the cursor speed in Gnome Terminal feels slow and sluggish.
By cursor speed I mean if say you were in the middle of a long line at a command prompt and you held down - how fast the cursor travels as well and general scrolling etc.
Yes if know you could use Ctrl+a to get to the start of a long line also - but I want to speed up the cursor speed in general.
Is this possible using gnome terminal or possibly using xset, e.g to slow down mouse pointer speed I typically use xset m 3/2 5.
If I dump xset, with xset q I get

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff

Does the value of repeat rate affect terminal cursor speed? otherwise, how can I increase cursor speed of gnome terminal?

  • Yes, it effects. E.g. use xset r rate 300 50 to wait for 300 ms between emitting the letter for the first and the second time, and then emit it 50 times per second. – egmont May 1 '16 at 11:21
  • @egmont thanks, this works for me. Do you know if xset r rate 300 50 will persist over reboots etc? – the_velour_fog May 1 '16 at 11:24
  • Most likely not. However, there's a corresponding graphical setting (in case of Gnome) in System Settings -> Keyboard which should be restored. – egmont May 1 '16 at 11:27
4

The cursor move speed is related to your keyboard's repetition rate you can use kbdrate to change it but it will change it globally.

sudo kbdrate 

will give you the current settings

Usage: kbdrate [-V] [-s] [-r rate] [-d delay]

I'm not really sure on this .. didn't look into it but I found that the delay is the time before the repeating starts and the rate is the speed of repeating ..the rate seems limited from 2 to 30.

I also do not really know the function of the -s switch ... I thought it was set but I was wrong since when using it .. the values didn't seem to change .. I had to use the command

sudo kbdrate -r 10 

or

sudo kbdrate -d 250 

to have the settings change.

This doesn't seem to be working in 16.04... I looked into it some more and also found you can try editing your X Server config

The option to look for would be

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "AutoRepeat" "<delay> <rate>".
EndSection
  • thanks, I'm testing it now. From the man page: -s Silent. No messages are printed – the_velour_fog May 1 '16 at 6:22
  • Unfortunately its not working for me on 16.04 – the_velour_fog May 1 '16 at 6:27
  • I seemed to not notice a difference if I tried to change my rate either .. after posting this I was playing with it ... and I guess i may delete this answer because yeah .. it doesn't seem to be functioning anymore in the newer versions – John Orion May 1 '16 at 6:28
  • kbdrate is for the Linux text mode console. For the graphical (X11) environment you need xset r. – egmont May 1 '16 at 11:16
  • is it kbdrate for ubuntu 16.04 LTS terminal or xset r ? And what's the right setting ? there don't seem to be a clear answer here. Thanks – Louis Jun 13 '17 at 7:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.