I'm trying to get Ubuntu Server set up and have got it installed, however it does not recognize my wired network adapter. It is at this point I should say that I am completely new to Linux. It does recognize my wireless adapter, but for some reason I simply cannot understand, WPA2 support is apparently not built in and I have to install wpa_supplicant.

This is complicated by the fact that I cannot connect to the network with this Ubuntu machine.

So I have downloaded the package, figured out how to mount the USB drive, unpacked the .tar.gz file and now cannot for the life of me figure out how to install the package. Everything I've read says to just type ./configure, then make, then make install. ./configure, however, just gives me an error that says no such file or directory.

I've tried to search and find an answer, but everything is telling me to use things that aren't installed so I'm at a catch-22. I can't install things because I can't connect to the internet, and can't connect to the internet because I can't install things.

Can someone please help me figure out how to install this package? I'm about to pull my hair out because it's broken and I'm compelled to fix it.

  • wpa_supplicant is not installed on my system either, however, the wireless works perfectly. What have you tried in order to get it connected?
    – chili555
    May 1, 2016 at 2:15

2 Answers 2


That package is included in the install media. I just ran into this same issue and here is how I solved it. (Assuming CD/DVD but procedure should be similar for USB stick)

We will start by editing the apt sources list to give us access to the packages on the install media

sudo vi /etc/apt/sources.list OR
sudo nano /etc/apt/sources.list OR
insert favorite text editer

Now at the very top there should be a couple of lines that start with:

deb cdrom:

Uncomment one of the lines (remove the # at beginning). You also must make sure that your DVD is inserted and mounted. It was not in my case so I ran the following to get it mounted.

sudo mount /dev/sr0 /media/cdrom

Now you should be able to install as you normally would

sudo apt install wpasupplicant

Happy Networking!


You can download the file as a deb package and you will be able to install it without having to compile anything.

You can get the deb packages HERE

Choose your version and then download the .deb file under Downloadable files section.

Once you have downloaded that and have it on your Ubuntu machine I will give you step by step instructions since you noted you are new to Ubuntu.

The easiest way for me to do this would be for me to tell you to copy the file from the USB to your desktop. I'm assuming you have a file manager and can do that easily.

OK first we want to open a terminal. now in the terminal type

cd Desktop

and press enter *note the capital D in desktop .. cd desktop will come back with an error.. it is case sensitive.

Now you will need to type the following but change the name to the name of the file you needed to download.

sudo dpkg -i ~/Desktop/wpasupplicant_0.7.3-6ubuntu2_amd64.deb

if it runs into dependency problems you are going to have more issues because of course you will need to download those also.

  • OK I think that ran correctly. May 3, 2016 at 15:57
  • Did it solve your initial issue .. is your wired network functioning now?
    – John Orion
    May 3, 2016 at 17:28
  • No I gave up on the wired and was hoping to get the wireless working. I'll have to find the steps for configuration again and give it a try. May 3, 2016 at 17:41
  • Well I ended up fixing it by installing Ubuntu Desktop and downloading server packages through sudo apt-get install tasksel. May 4, 2016 at 19:06
  • glad to hear you got it fixed .. sorry i wasn't of more help
    – John Orion
    May 4, 2016 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.