20

When trying to upgrade using the terminal, my upgrade stops. This is the line showing in the terminal:

The required dependency 'apt(>=1.0.10.2 ubuntu2)' is not installed.

my problem is that I don't know the command to install this dependency. Using other commands, it says apt is up to date. Solutions?

14
  • Have you tried using sudo apt-get update, sudo apt-get upgrade, and sudo apt-get install -f?
    – Andrew
    Apr 30 '16 at 23:04
  • yes, i've used all those commands. first two said i was up to date but terminal didn't recognize th install -f command
    – paul
    Apr 30 '16 at 23:07
  • Have you tried sudo apt-get -y install apt ?
    – Andrew
    Apr 30 '16 at 23:11
  • answer,again is apt is already the newest version
    – paul
    Apr 30 '16 at 23:12
  • no matter the install apt command i've tried, it always says i'm up to date!
    – paul
    Apr 30 '16 at 23:13
19

Had the same problem, solved by forcing the update of apt and cleaning the current installation as Andrew suggested:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install   # (not "install -f"!)
sudo apt-get -y install apt
sudo do-release-upgrade
4
  • 5
    there is something else blocking my installation of apt. following the instructions listed, it still indicates that apt is up-to-date. however, when i get to do-release-upgrade, it cannot find apt, or at least the correct apt.
    – paul
    May 7 '16 at 3:27
  • 1
    -f install and install -f make no difference.
    – Pilot6
    Jul 31 '16 at 8:08
  • But that install from 15.10 to 16.xx sth.
    – marko
    Sep 24 '16 at 19:43
  • @marko You just need to repeat the step a few times.
    – wsw
    Jun 2 '18 at 19:17
13

I had this error, for me I was missing the wily-updates line from my /etc/apt/sources.list:

deb http://archive.ubuntu.com/ubuntu/ wily-updates main restricted universe multiverse
4
  • 1
    For ARM etc. the line should be deb http://ports.ubuntu.com/ wily-updates main restricted universe multiverse Aug 8 '16 at 1:46
  • I'm thinking that it should be "deb ports.ubuntu.com trusty-updates main restricted universe multiverse" (i.e., it turns on the extra repos). Mixing versions (e.g., trusty and wily) never ends well.
    – joat
    Nov 14 '16 at 9:36
  • After doing that, "apt-get update && apt-get -y upgrade && do-release-upgrade" appears to work. Note: you may need to comment out the /tmp line in /etc/fstab, to avoid running out of temporary space.
    – joat
    Nov 14 '16 at 9:54
  • This is essential if you upgrading from old Ubuntu version, like 15.xx. Also keep in mind that they no longer provide archive.ubuntu.com/ubuntu url for wily and other old releases. Use old-releases.ubuntu.com/ubuntu instead.
    – Evgeniy
    Nov 4 '19 at 18:51
4

I had this issue too, this will update all your goodies as well as upgrade from 15 to 16.

Go to Software and Updates > Updates

Tick On the Following

  • Wily Security
  • Wily Updates
  • Wily Proposed

Update and Upgrade Current System

sudo apt-get update && sudo apt-get upgrade

Get the Upgrade

sudo apt-get dist-upgrade

Upgrade in CLI

sudo do-release-upgrade
1

I had the exact same problem with 'apt'. I got the solution from this link. Run sudo dpkg -l | grep apt. You may see this entry in the output of the command :

ii  apt 1.0.10.2ubuntu1      amd64         commandline package manager

If you do, you will need to get the required apt(>=1.0.10.2 ubuntu2). Here are the steps which I followed :

  1. Go to Software & Update -> Ubuntu Software . Change the Server to Main server.(in my case, I changed to Server for India). I was using a different mirror previously and hence had an older 'apt' version.

  2. Run

        sudo apt-get update
        sudo apt-get install --reinstall apt 
    
  3. Run sudo dpkg -l | grep apt again to check version has changed. Hopefully the entry in the output should have changed to : apt 1.0.10.2ubuntu2.

  4. Run a sudo apt-get update && sudo apt-get upgrade following which you can proceed to update to ubuntu 16.04.

3
  • followed the advice listed. the command package manager did come up with ver. 1.0.10.2 ubuntu1. but the two commands to change to ubuntu2 did not yield a change(still ubuntu1). as this a security change, could it be caused by a security problem?
    – paul
    May 8 '16 at 18:12
  • I am by no means an expert in this, but I think an another alternative would be to use this deb to perhaps solve the problem.
    – Rahul
    May 8 '16 at 18:24
  • i am uncomfortable downloading and installing ubuntu2 files until i can establish why the files are not available through the command line(terminal). i have limited experience extracting and installing from a download.
    – paul
    May 8 '16 at 18:34
1

The former posted solutions didn't work for me.

What worked was, as found in the comments on launchpad:

wget http://launchpadlibrarian.net/254524267/apt_1.0.10.2ubuntu2_amd64.deb   
wget http://launchpadlibrarian.net/254524264/apt-transport-https_1.0.10.2ubuntu2_amd64.deb
wget http://launchpadlibrarian.net/254524266/apt-utils_1.0.10.2ubuntu2_amd64.deb    
wget http://launchpadlibrarian.net/254524269/libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb    
wget http://launchpadlibrarian.net/254524270/libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb

sudo dpkg --install apt_1.0.10.2ubuntu2_amd64.deb apt-transport-https_1.0.10.2ubuntu2_amd64.deb apt-utils_1.0.10.2ubuntu2_amd64.deb libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb

sudo do-release-upgrade

Not the answer you're looking for? Browse other questions tagged or ask your own question.