7

This question already has an answer here:

I've spent hours looking on the net, tried various things. One site said that this particular card is not supported by the b43 driver so I have to use wl. And make sure that b43 is blacklisted which I was unable to do (always I try to blacklist the b43 it says permission denied). So, is it even possible to use this network controller with Ubuntu (16.04) I've had my new laptop a week now and still not up and running - Win 10 works though :(

marked as duplicate by David Foerster, Arronical, Eric Carvalho, Pilot6, Kevin Bowen Sep 22 '16 at 19:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

7

Although I have read some questions that suggest it is troublesome, I have not yet read any report that says it absolutely will not work. It is easy enough to find out. Install the driver and see!

With a working internet connection by ethernet, tethered or whatever means possible, open a terminal and do:

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

The installation of the driver does the required blacklisting for you. However, if you wanted to undertake it manually, I suggest:

sudo gedit /etc/modprobe.d/blacklist.conf

Use nano or kate or leafpad if you don't have the text editor gedit. Add the following lines at the very end to the existing text:

blacklist b43
blacklist bcma
blacklist ssb

Proofread carefully, save and close the text editor. Reboot and tell us if the wireless is working.

  • I've carried out the first instructions, thank you - and the sudo gedit instruction brought up a text box so I added the blacklist instructions. However, the terminal reports... Gtk warning, and 2 gedit warnings - Set document metadata failed: setting attribute met adata::gedit-spell-enabled not supported On reboot it says connected but doesn't work :( – Johny London May 1 '16 at 10:44
  • I doubt that the edit to /etc/modprobe.d/blacklist.conf is at fault. Check: cat /etc/modprobe.d/blacklist.conf. If it is done correctly, it now reads like this: paste.ubuntu.com/16170671 If so, it is just fine. Tell me more about "connected but doesn't work." Can you ping? ping -c3 8.8.8.8 Are there any clues in the log? dmesg | grep wl? – chili555 May 1 '16 at 12:45
  • Exactly the opposite surely? It says to blacklist bcm43xx and use b43 and ssb - I think I'm supposed to use bcm43xx as in bcm43wl? – Johny London May 1 '16 at 14:23
  • The driver bcmwl-kernel-source creates a driver named wl. b43 and ssb need to be and are blacklisted for wl to work correctly. There was, at one time, a driver bcm43xx that was superceeded by b43 and ssb. bcm43xx doesn't even exist any longer and needn't be mentioned at all. – chili555 May 1 '16 at 16:12
  • Thanks for your help, chili555. When I say doesn't work I mean, it shows as connected on the top r/h icon, works slowly for a minute, then stops working. I tried a little experiment plugging in a usb wifi (Netgear WG111T) which to be honest just muddied the waters. I'd had the lan cable connected, then I had internet for a bit, but slowly. I noticed there were three different settings in the box for Device (in edit wifi settings) As I write I'm connected via the cable, and that box shows wlx00146ce85d48 with an option for wlo 1 (the later I presume is the Broadcom). I'm really at a loss here. – Johny London May 2 '16 at 14:21
1

Mind that there's also a secure boot connection. If you have secure boot enabled in your BIOS, the wifi may not be properly detected in Ubuntu now. Disabling secure boot instantly resolves that and all will work fine.

This was the case on a HP 250 G4 with the BCM43142 wifi/bluetooth module.

I've read about this elsewhere as well, that having secure boot turned on can cause grief for some drivers. Sigh.

  • I seem to remember having to disable that right from the off, when I was trying to get Ubuntu to dual boot with win10. – Johny London Jul 29 '16 at 12:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.