34

I'm trying to install Django using

sudo apt-get install python-django

But I'm getting error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-django is already the newest version.
The following packages were automatically installed and are no longer required:
  bacula-common codeblocks-common enscript g++-4.9 g++-4.9-multilib
  geany-common lib32stdc++-4.9-dev libabw-0.1-1 libboost-date-time1.58.0
  libboost-filesystem1.55.0 libboost-iostreams1.55.0 libboost-iostreams1.58.0
  libcdr-0.1-1v5 libcmis-0.5-5v5 libcodeblocks0 libdb5.3-java
  libdb5.3-java-jni libe-book-0.1-1 libeot0 libetonyek-0.1-1 libfreehand-0.1-1
  libhogweed2 libinput0 libjavascriptcoregtk-1.0-0 libmirclient8
  libmirclient8driver-mesa libmircommon2 libmircommon3 libmirprotobuf0
  libmspub-0.1-1 libmwaw-0.3-3 libodfgen-0.1-1 liborcus-0.10-0v5
  libpagemaker-0.0-0 libpoppler46 libqjson0 librevenge-0.0-0
  libspice-client-gtk-2.0-4 libts-0.0-0 libvisio-0.1-1 libwebkitgtk-1.0-0
  libwebkitgtk-1.0-common libwpd-0.10-10 libwpg-0.3-3 libwps-0.3-3
  libwps-0.4-4 libwxbase2.8-0 libwxgtk2.8-0 libx32stdc++-4.9-dev libxen-4.4
  linux-headers-3.19.0-15 linux-headers-3.19.0-15-generic
  linux-image-3.19.0-15-generic linux-image-extra-3.19.0-15-generic
  m17n-contrib mir-client-platform-mesa2 pgdg-keyring python-lzma
  python-parsley python-psutil python-spice-client-gtk python-support
  python-twisted python-twisted-conch python-twisted-lore python-twisted-mail
  python-twisted-names python-twisted-news python-twisted-runner
  python-twisted-words python-txsocksx qml-module-qt-labs-folderlistmodel
  qml-module-qt-labs-settings qtdeclarative5-ubuntu-web-plugin-assets quvi
  tsconf upstart-bin
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 228 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up runit (2.1.2-3ubuntu1) ...
start: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
dpkg: error processing package runit (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of git-daemon-run:
 git-daemon-run depends on runit; however:
  Package runit is not configured yet.

dpkg: error processing package git-daemon-run (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 runit
 git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)

So then I try

sudo dpkg --configure -a

Then I again getting error:

Setting up runit (2.1.2-3ubuntu1) ...
start: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
dpkg: error processing package runit (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of git-daemon-run:
 git-daemon-run depends on runit; however:
  Package runit is not configured yet.

dpkg: error processing package git-daemon-run (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 runit
 git-daemon-run

Then I try

sudo apt-get install --reinstall runit

then I get

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 226 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
E: Internal Error, No file name for runit:amd64

Then I try:

sudo apt-get install --reinstall runit

then I get error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 226 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
E: Internal Error, No file name for runit:amd64

then I try:

sudo apt-get install runit

then I get error

start: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
dpkg: error processing package runit (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of git-daemon-run:
 git-daemon-run depends on runit; however:
  Package runit is not configured yet.

dpkg: error processing package git-daemon-run (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 runit
 git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)

Then I try forcibly remove `runit.So I run

sudo dpkg -r --force-all runit
the output of command is:
dpkg: runit: dependency problems, but removing anyway as you requested:
 git-daemon-run depends on runit.

(Reading database ... 689195 files and directories currently installed.)
Removing runit (2.1.2-3ubuntu1) ...
stop: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
Removing SV inittab entry...
Processing triggers for man-db (2.7.4-1) ...

Then I run:

sudo apt-get -f install runit

Then I again get the error:

dpkg: error processing package runit (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of git-daemon-run:
 git-daemon-run depends on runit; however:
  Package runit is not configured yet.

dpkg: error processing package git-daemon-run (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 runit
 git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'm runnig Ubuntu 15.04.Please help me with it.

0
79

I was having a similar problem after I recently upgraded to Ubuntu 16.04. I found this answer and Jonathan's purge and reinstall commands took care of it for me. Hope this helps.

sudo apt-get purge runit
sudo apt-get purge git-all
sudo apt-get purge git
sudo apt-get autoremove
sudo apt update
sudo apt install git
1
  • This helped me when I was trying to install elementary-sdk and getting errors.
    – omukiguy
    Jan 22 '18 at 17:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.