3

After a fresh install (16.04) to my notebook which have Nvidia GT 750m, I want to change GPU driver from "Software & Updates" --> "Additional Drivers". System identifies my graphic card, no problem but when I select a proprietary driver and apply changes. After a few seconds, change bar stops and nouveau selected by default again.

I tried from terminal;

sudo apt-get install nvidia-361

but output says "you have held broken packages"

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-361 : Depends: lib32gcc1 but it is not going to be installed
              Depends: libc6-i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Then issue is not about nvidia-361, all drivers are same.

2

In ubuntu 16.04, if Software & Updates -> Additional Drivers, is started from menu or Unity launcher, choosing a proprietary driver doesn't work. Upon selecting a new driver and clicking apply changes, progress bar moves forward for sometime, then goes back and the previous driver is selected again.

It looks like the issue is that Software & Updates is initialized without super user privileges. The solution is, open a terminal and type:

$ sudo software-properties-gtk

And type password if required. Then select the proprietary driver and click apply changes.

This method solved me the problem.

PS : Edited after seeing the comments.

| improve this answer | |
  • Please make your answer more complete. – Star OS Jun 11 '16 at 13:21
  • You might be able to improve this answer with providing the steps needed in more detail and maybe even adding screen-shots of different parts to make it a rock solid answer. – Videonauth Jun 11 '16 at 13:50
0

16.04 is new and all packages are not ready to use in all servers. The problem is not about nvidia drivers or anything about broken pacages.

Using Main Server to download packages solve my problem.

  1. System Settings
  2. Software & Updates
  3. Select "Main Server" from "Download from" section
| improve this answer | |
  • I get nvidia-390: Depends: x11-common (>= 1:7.0.0) but 1:7.7+13ubuntu3 is to be installed Depends: libgl1 but it is a virtual package Depends: xorg-video-abi-24 but it is not going to be installed – Sören Sep 17 '18 at 23:48
-1

You have a problem with the package system, not with the driver itself. It is quite a common problem. One of the solutions is:

sudo apt-get clean
sudo apt-get install -f
sudo dpkg --configure -a

Another possible solution is to use synaptic package manager to fix the broken packages (it will prompt you to do that automatically) and then you'll be able to install nvidia-361.

Source: Package system is broken. How to fix it?

| improve this answer | |
  • Please don't copy other peoples answers from the site as yours, leave a comment below the question saying it is a duplicate -1 – Mark Kirby Apr 30 '16 at 16:14
  • This isn't a duplicate, he's not asking about broken packages, but about problems installing a driver with some diagnostics. – Dugi Apr 30 '16 at 17:15
  • 1
    It is not works.. "sudo apt-get install -f nvidia-361" gives broken packages error. – al0s Apr 30 '16 at 17:19
  • Try to use Synaptic Package Manager, if it finds broken packages, it will ask you if you want it to fix them for you. – Dugi Apr 30 '16 at 17:22
  • Then why did you link another question on the site as your source if it is not the same answer? – Mark Kirby Apr 30 '16 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.