0

I upgraded a KUbuntu 14.04 LTS install to xorg-core-lts-wily and all its dependencies, in order to be able to run on a 6th gen i3 with a HD520 graphics.

That meant I lost wine, and I cannot seem to get it reinstalled. Even when following the instructions at Wine installation isue after upgrade 12.04 -> 14.04 (= using the ubuntu-wine/ppa PPA) I still get the following:

> env LC_ALL=C sudo aptitude -s install wine1.8
The following NEW packages will be installed:
  fonts-horai-umefont{a} libasn1-8-heimdal:i386{a} libasound2:i386{a} libasound2-plugins:i386{a} libasyncns0:i386{a} 
  libavahi-client3:i386{a} libavahi-common-data:i386{a} libavahi-common3:i386{a} libcapi20-3{a} libcapi20-3:i386{a} 
  libcups2:i386{a} libdrm-amdgpu1:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} libdrm-radeon1:i386{a} libedit2:i386{a} 
  libelf1:i386{a} libexif12:i386{a} libflac8:i386{a} libgcrypt11:i386{a} libgd3:i386{a} libgif4:i386{a} 
  libgl1-mesa-dri-lts-wily:i386{a} libgl1-mesa-glx-lts-wily:i386{a} libglapi-mesa-lts-wily:i386{a} libglu1-mesa:i386{a} 
  libgnutls26:i386{a} libgpg-error0:i386{a} libgphoto2-6:i386{a} libgphoto2-port10:i386{a} libgssapi-krb5-2:i386{a} 
  libgssapi3-heimdal:i386{a} libgstreamer-plugins-base0.10-0:i386{a} libgstreamer0.10-0:i386{a} libhcrypto4-heimdal:i386{a} 
  libheimbase1-heimdal:i386{a} libheimntlm0-heimdal:i386{a} libhx509-5-heimdal:i386{a} libieee1284-3:i386{a} 
  libjack-jackd2-0:i386{a} libjbig0:i386{a} libjpeg-turbo8:i386{a} libjpeg8:i386{a} libk5crypto3:i386{a} libkeyutils1:i386{a} 
  libkrb5-26-heimdal:i386{a} libkrb5-3:i386{a} libkrb5support0:i386{a} liblcms2-2:i386{a} libldap-2.4-2:i386{a} 
  libllvm3.6:i386{a} libltdl7:i386{a} libmpg123-0:i386{a} libogg0:i386{a} libopenal1:i386{a} liborc-0.4-0:i386{a} libosmesa6{a} 
  libosmesa6:i386{a} libp11-kit0:i386{a} libpcap0.8:i386{a} libpciaccess0:i386{a} libpulse0:i386{a} libroken18-heimdal:i386{a} 
  libsamplerate0:i386{a} libsane:i386{a} libsasl2-2:i386{a} libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} 
  libsndfile1:i386{a} libspeexdsp1:i386{a} libsqlite3-0:i386{ab} libssl1.0.0:i386{a} libtasn1-6:i386{a} libtiff5:i386{a} 
  libtxc-dxtn-s2tc0:i386{a} libusb-1.0-0:i386{a} libv4l-0:i386{a} libv4lconvert0:i386{a} libvorbis0a:i386{a} 
  libvorbisenc2:i386{a} libvpx1:i386{a} libwind0-heimdal:i386{a} libwrap0:i386{a} libx11-xcb1:i386{a} libxcb-dri2-0:i386{a} 
  libxcb-dri3-0:i386{a} libxcb-glx0:i386{a} libxcb-present0:i386{a} libxcb-sync1:i386{a} libxcomposite1:i386{a} 
  libxcursor1:i386{a} libxi6:i386{a} libxinerama1:i386{a} libxml2:i386{a} libxpm4:i386{a} libxrandr2:i386{a} 
  libxshmfence1:i386{a} libxslt1.1:i386{a} libxt6:i386{a} libxxf86vm1:i386{a} ocl-icd-libopencl1:i386{a} 
  p11-kit-modules:i386{a} wine-gecko2.34{a} wine-gecko2.34:i386{a} wine-mono4.5.4{a} wine1.8 wine1.8-amd64{a} 
  wine1.8-i386:i386{a} 
0 packages upgraded, 108 newly installed, 0 to remove and 3 not upgraded.
Need to get 184 MB of archives. After unpacking 615 MB will be used.
The following packages have unmet dependencies:
 libsqlite3-0 : Breaks: libsqlite3-0:i386 (!= 3.8.4.3-3) but 3.8.2-1ubuntu2.1 is to be installed.
 libsqlite3-0:i386 : Breaks: libsqlite3-0 (!= 3.8.2-1ubuntu2.1) but 3.8.4.3-3 is installed.
The following actions will resolve these dependencies:

      Keep the following packages at their current version:
1)      libgssapi3-heimdal:i386 [Not Installed]            
2)      libheimntlm0-heimdal:i386 [Not Installed]          
3)      libkrb5-26-heimdal:i386 [Not Installed]            
4)      libldap-2.4-2:i386 [Not Installed]                 
5)      libsqlite3-0:i386 [Not Installed]                  
6)      wine1.8 [Not Installed]                            
7)      wine1.8-amd64 [Not Installed]                      
8)      wine1.8-i386:i386 [Not Installed]                  

      Leave the following dependencies unresolved:         
9)      wine-gecko2.34 recommends wine1.5-amd64            
10)     wine-gecko2.34:i386 recommends wine1.5-i386:i386   


Accept this solution? [Y/n/q/?] n  
open: 794; closed: 954; defer: 734; conflict: 1264                                                                                 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 823; closed: 964; defer: 742; conflict: 1272                                                                                 
^C

Using apt-get I'm seeing:

> env LC_ALL=C sudo apt-get -V install wine1.8 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.8 : Depends: wine1.8-i386 (= 1:1.8.0-0ubuntu1)
E: Unable to correct problems, you have held broken packages.
Exit 100

The alternative seems to be to uninstall just about everything else I need, which is evidently not an option.

Is there a workaround, preferably one that doesn't involve setting up an appropriate PPA myself?

For the record: the 3 not upgraded packages mentioned are held packages that are not broken and have nothing to do with wine.

  • What does LC_ALL=C sudo apt-get install wine1.8 outputs? – Hi-Angel May 8 '16 at 14:53
  • I've added the requested output. It's less useful than what aptitude shows ... – RJVB May 17 '16 at 12:13
  • Indeed. Well, I'm not really sure what's the problem. But what happens if you try to install both libsqlite3-0 and libsqlite3-0:i386? FWIW I've installed both of them. EDIT: also, does anything change if you try installing wine, i.e. without the version? – Hi-Angel May 17 '16 at 12:24
  • You've got something there. It turns out I have a number of core sqlite3 packages that are at 3.8.4.3-3 which exist only in amd64 and not i386. I cannot seem to find what PPA those came from. Is it possible to check if any packages require that new version, and if not, how do I downgrade all concerned sqlite3* and libsqlite3* packages in a single go? (Or else I might just download all .deb files and see what gives, knowing I can always reinstall the newer versions in that case). – RJVB May 19 '16 at 8:14
  • Enter apt-cache policy sqlite3-0-whatever-version-installed, it would show its PPA. Then use ppa-purge utility which would both remove the PPA, and revert its packages to the vanilla version. – Hi-Angel May 19 '16 at 10:41
1

Thanks Hi-Angel.

The issue here was indeed a package version conflict situation. It turns out that I backported that 3.8.4 sqlite3 package from (then) Debian Testing about 2y ago, and then completely forgot about it. Evidently. I didn't use a PPA, so got only the 64-bit packages.

I solved the issue by grabbing an even more recent 3.8 version (3.8.11) from Launchpad, and uploading that package to one of my PPAs (ppa:rjvbertin/misc in case anyone is interested). That was the most straightforward way to get all installed sqlite3 packages on the same version - and then wine1.8 installed fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.