After upgrading from kubuntu 15.10 to 16.04, the login screen hangs right after typing the (correct) password and pressing enter. The controls like the text field are disabled and brightness slightly dimmed, then nothing else happens.

By switching to a text console with Ctrl+Alt+F1 and back to X with Ctrl+Alt+F7 I can get into the logged in session, so it seems the screen is just not being updated during login where normally the progress bar is shown.

This doesn't happen always, but most of the time.

It is running on a Lenovo L420 with Intel integrated graphics. Running in VirtualBox on another PC, this does not happen.

Is this a known issue or bug? I wasn't able to find any posts or reports about it.

  • 1
    Did you place any bash scripts in your etc/profile.d directory? The same thing happened to me when I tried to run some bash scripts at the start of a session (from the profile.d folder). Everything worked ok after I deleted the files that I added. – Ross May 3 '16 at 3:30
  • I checked that, there are no custom scripts in there. – Torsten Römer May 5 '16 at 20:09
  • I have almost the exact same symptom with Intel graphics. I'm not certain about the text console. I got rid of my .kde folder and that allowed me to log in (but crippled). I have to remove it before logging in each time (even without changing anything). Do you also have this symptom: "ERROR* CPU pipe A FIFO underrun" in syslog? It causes the screen to not be updated. – Alan Robertson Sep 14 '16 at 15:16
  • 1
    OK. I now checked that the Ctrl+ALT+F1/F7 combination works for me as well - and it's definitely associated with the ksshaskpass program for me. I've created an Ubuntu bug for this problem - you can find it here: bugs.launchpad.net/ubuntu/+source/xorg/+bug/1623969 – Alan Robertson Sep 15 '16 at 14:31

Recently I encountered this problem with kubuntu 16.04 SDDM login screen hangs. The issue occurred after I installed kubuntu 16.04 on an Intel i7-7700k with Intel 630 HD graphics and then updated to the latest packages.

I was able to login using the workaround of using Ctrl+Alt+F1 to get to a text console and then Ctrl+Alt+F7 to get back to X and the logged in session.

I stumbled upon a fix to the login hang while I was working to get rid of a screen tearing problem. The fix involves changing the compositor rendering backend from XRender to OpenGL.

More specifically to address the hang on login and problem with screen tearing I did the following:


A) Start K -> Settings -> System Settings

     Under Hardware section
     Double-click Display and Monitor
       Choose Compositor on LHS
         Enable compositor on startup:  Checked               # was checked
         Rendering backend:             OpenGL 3.1            # was XRender
         OpenGL interface:              GLX
         Tearing prevention ("vsync"):  Full screen repaints  # was Automatic
          Ignore message "Full screen repaints" can cause performance problems.
       Click Apply


Bug 321589 - Automatic VSync strategy causes tearing

Screen Tearing on Kubuntu 16.04 with Intel Drivers?

B) Set KWIN variables.

Edit /etc/environment and add the top and bottom line:




Listed as also working with NVidia.

I hope the above steps help others get rid of the login hang and screen tearing problems.

  • 1
    The login hangs were gone after updating to 16.10, so unfortunately I cannot confirm but I am sure it does solve the issue. Great hint regarding tearing - for me it already completely went away by switching from XRender to OpenGL 3.1, no other settings were needed :-) – Torsten Römer Jan 22 '17 at 18:31
  • Stumbled over the same problem... thanks for the detailed instructions. For me too, it was sufficient to switch from XRender to OpenGL 3.1 to fix the problem. – Malte Skoruppa Jan 15 '18 at 10:17

Check the ownership of the .Xauthority file in your home directory. If it is owned by root delete it, or take ownership. See for instance Ownership of .Xauthority transferred to root for more information.

  • I checked that, I'm the owner. – Torsten Römer May 5 '16 at 20:09
  • 1
    If your answer is essentially a referral to another question, it would be better to flag this question as a duplicate of the other (with the [flag] button below this one). – David Foerster May 23 '16 at 13:12

Finaly it started to work for me. There is a problem in a user configuration files. I have installed nodm for some time, started X as a root, created new account, and switched few times between the users. Make sure you have OpenGl 3.1 selected as a default renderer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.