4

I have just installed bash in windows 10 insider preview. But gedit is not working. I also use software R for my statistical work, its lot of options like 'plot' also not working. Is it the fact that no program like gedit can be opened through bash I mean wont that support any GUI ?

7

Ubuntu on Windows does not support the X11 window system, which is needed for graphical applications in Linux. People have managed to use Xming to get things to work (with Cygwin's X suggested as an alternative), but it's not very stable. YMMV. It's not official, and if anything breaks, don't ask here.

  • So, is it official that windows wont support GUI or in future stable version they will support? – Debarghya Apr 30 '16 at 7:59
  • All official mentions of this have solely been about command line programs. No MS blog or announcement has mentioned GUI programs. And Scott Hanselman says that GUI is "absolutely not the use case". Make of that what you will. – muru Apr 30 '16 at 8:11
  • @muru Have you evaluated at other x-windows packages for windows like vcXsrv or x2go? – WinEunuuchs2Unix Oct 8 '17 at 0:22
3

Although WSL does not include X-Windows, you can run a X-Windows in the Windows Operating System and display the linux applications in the same desktop. There are many tutorials and blog entries you may check.

Running Applications

  • I use VcSrv Windows X Server, but you can use the old Xming or the Cygwin X Server. For VcXrv, you only need to download and install the software.
  • After starting the X-Windows, you must instruct Linux to use the desktop

    $ export DISPLAY=:0
    
  • Then, you can install and run linux applications that use a graphical user interface. For instance, to run xeyes you may run

    $ sudo apt-get install x11-apps
    $ xeyes
    

Running a Unix Desktop

Ubuntu uses Unity or GNOME as a desktop. There are some people that have been trying to run a Unix desktop in the WSL. The instructions are also included in an issue in the Github.

  • Run the X-Windows in a standalone window to avoid confusion with the Windows desktop. Run the XLaunch windows program and select the "One large window" or the "Fullscreen" mode. You must close any other running X-Windows.
  • Install the desktop packages.

    $ sudo apt-get install ubuntu-desktop unity compizconfig-settings-manager
    
  • Use the local X-Windows and configure the compiz windows manager

    $ export DISPLAY=:0
    $ ccsm
    
  • Run the desktop

    $ compiz 
    

There are some message errors caused by some initialization not performed by the WSL. I had problems with the graphical acceleration in some packages. You may try the GNOME classic desktop flashback instead the default one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.