In the latest version of Ubuntu LTS 16.04 google chrome will not install. once downloaded software install opens when install is clicked it immediately fails. It worked fine with Ubuntu 14 LTS.


This is a known bug in the Ubuntu 16.04 LTS (GNOME) Software application, but you can install Google Chrome in an alternative way ... open a terminal and execute the following commands :

echo "deb http://dl.google.com/linux/chrome/deb/ stable main" | sudo tee /etc/apt/sources.list.d/google-chrome.list  

wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | sudo apt-key add -  

sudo apt-get update  

sudo apt-get install google-chrome-stable
  • 1
    It's the best solution. – Kostya Bakay Aug 9 '16 at 9:25
  • I am running Gnome 3 16.04 LTS and I get the error E: Unable to locate package google-chrome-stable – SumNeuron Jul 11 '17 at 23:19

Alternatively you can install it with gdebi package installer

sudo apt-get install gdebi

then right click your .deb file and open with > select Gdebi package installer

  • helped me again :) – awebartisan Oct 14 '17 at 13:04

This is a known bug - but this workaround has worked for me successfully so far on 16.04.


cd /Downloads

sudo dpkg -i awesome_new_app.deb

sudo apt-get -f install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.