2

I'm relatively new to Linux, have been using it for about 6 months already. I like Gnome shell more than Unity but looks like in 16.04 Ubuntu plays a trick on me. As soon as I install gnome Ubuntu gets stuck on loading.

Basically I did the following:

sudo apt install gnome-shell

Installation process is done and then I do:

sudo reboot

Regardless if I do the

sudo apt update && sudo apt upgrade -y

First it still ends up with the same result. Also it does not matter if I really switch to gnome or not before I do reboot. The only thing I can do after installing gnome and rebooting is basically booting with GRUB and logging into the system via safe mode and removing the gnome shell. As soon as done the system loads perfectly fine as it's supposed to.

Anyway this has not been a problem for me in the 14.04 at all and I was unable to google any good solutions so far.

I run Ubuntu on Dell Inspiron 5558 laptop, if that's of any help at all. And also I do use proprietary Nvidia drivers (361.42) instead of default nuoveau drivers.

4

Press Ctrl+Alt+F1 when it hangs to start text-mode. Type in your username and password to login.

From there, you need to enable lightdm or gdm, depending on what gnome is configured to:

sudo dpkg-reconfigure lightdm
  • I read your comment on another answer saying that you did not switch to gnome after you installed it. You might need to enable gdm, in that case. Just change out lightdm with gdm in the command, and it should be fine. If that doesnt work, the command in my answer should give a "gui" where you can choose gdm or lightdm either way. – vegarab Mar 14 '17 at 21:28
  • omg, this actually led to solving my issue. It was a long shot, but in gnome 3, I have run sudo apt-get gdm3 (as the sudo dpkg-reconfigure gdm3 reported that it wasn't installed) and the login screen showed up again. Helps still in 2017 :) Thanks very much. – Aleks Oct 16 '17 at 3:08
1

Try by selecting lightdm instead of gdm when installing gnome-shell. That worked for me.

You can uninstall gnome-shell and re-install it to be able to choose it again.

To get a root console, enter in recovery mode by pressing Shift key on GRUB booting time.

Good luck.

0

Disclaimer: this is NOT an answer, I'm just sharing the workaround I've used

After 5 versions of Ubuntu run on Gnome Shell (without a single problem), the update to 16.04 has broken it completely.

In my case, logging in with Gnome Shell lead to a screen where the only two things working were the hot corner and the highlighting of the Desktop icons.

After the first click (on the top bar, on the side bar, on an icon, everywhere) it did get stuck and needed a hard reset.

Meanwhile that the problem get fixed, the workaround to use is simpler than the one you're describing (if I got it right): in the login page, switch from GnomeShell to standard Ubuntu by clicking the circular icon:

enter image description here

This way everything will work perfectly (but you'll miss the hot corner as hell).

  • 2
    The problem is that I do not even get to see the GUI, I just see it stuck on a black screen after I see the Ubuntu status bar with logo, after which I'd normally see the login screen. The tricky part is - after I install gnome shell I do not switch immediately to it. I simply install it and reboot and get into this problem. On another hand I successfully use it on another machine which has an integrated video card unlike my Dell Inspiron 5558 laptop with GeForce 920M. I think may the problem is with the video driver compatibility or something. – Eugene Korshunovich May 6 '16 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.