14

When I installed 16.04, I mistakenly chose the German keyboard layout. My computer is a Japanese computer with Japanese keys, but I regularly use several languages. How can I change the default system layout for all of my languages without reinstalling the OS? I cannot for the life of me find a GUI or CLI way to do this. Many thanks for your help.

  • Is it sufficient to change it for your own user? In that case System Settings -> Text Entry should be what you need. – Gunnar Hjalmarsson Apr 29 '16 at 15:44
  • Gunnar, thanks for your suggestion. I can add and remove text entry methods just fine, but this doesn't seem to solve the problem for me. Even if I add another Japanese text entry method, the keyboard layout doesn't change. E.g., I press the @ key and another character comes out. Also, I would prefer to change the default layout, as my passwords on the login key also depend on symbols that have unique locations on the Japanese keyboard. – Slim Down May 4 '16 at 1:46
4

I'm not able to reproduce the problem you have mentioned in comments, i.e. that enabling a Japanese keyboard layout wouldn't make a difference. I added Japanese, and the resulting keyboard layout looks like this:

Japanese keyboard layout

Then I opened gedit, switched to "Ja" via the input source indicator, and the expected characters according to the image above appeared when I typed.

| improve this answer | |
  • Gunnar, thank you for your kind help and persistence. Having not worked previously, I re-added "Japanese" within All Settings / Text Entry, and this time, it seems to have worked, both for "Japanese" and the "Japanese (Mozc)(iBus)" that I normally use. While I am pleased, I am most puzzled as to why it worked this time and not before. In any case, thank you. – Slim Down May 4 '16 at 5:47
  • @SlimDown: Glad that you made it work. :) – Gunnar Hjalmarsson May 4 '16 at 6:38
  • I have just recently set up another machine and run into the same issue. This time, I opened up IBus preferences in a terminal, ibus-setup and un-toggled Advanced --> Use system keyboard layout. Again, I'm not sure why, but this seems to have worked. Anyone still having issues after following the method above, try the IBus preferences. – Slim Down Aug 26 '16 at 3:56
15

In a shell:

sudo dpkg-reconfigure keyboard-configuration
| improve this answer | |
  • ubibene, thank you for your suggestion. I tried your suggestion and configured my board for Japanese layout, then rebooted, but the problem persists. I.e., the outputs do not match the keys I press. Not sure what the problem is. Could this be a bug? – Slim Down May 4 '16 at 1:54
  • @SlimDown: What's the output of cat /etc/default/keyboard? – Gunnar Hjalmarsson May 4 '16 at 4:51
  • # KEYBOARD CONFIGURATION FILE # Consult the keyboard(5) manual page. XKBMODEL="asus_laptop" XKBLAYOUT="jp" XKBVARIANT="OADG109A" XKBOPTIONS="" BACKSPACE="guess" – Slim Down May 4 '16 at 5:47
  • @SlimDown: That ought to be applied by the login greeter. Can't tell why it isn't for you. – Gunnar Hjalmarsson May 4 '16 at 6:35
  • 3
    Great solution. – Marc van Dongen Jun 30 '16 at 8:24
1

Install "Japanese iBus MOZC" Keyboard:

sudo apt-get install ibus-mozc mozc-server mozc-utils-gui

Re-login (this is important!) and find mozc in System Settings -> Text Entry when you click the + button.

If "your" Japanese is not listed, enter this command in shell

im-config 

After that you should have these Japanese keyboard input sources in Text Entry when you click the + button: Japanese (Dvorak), Japanese (Kana), Japanese (Kana 86), Japanese (Macintosh), Japanese (Mozc)(IBus), Japanese (OADG 109A), Japanese (PC-98xx Series)

| improve this answer | |
  • PeterN, thank you for your suggestions. I should have mentioned in my question that I regularly use Japanese iBus MOZC, and have already tried un- and reinstalling, with reboots. I also tried your second suggestion in a terminal, but that did not seem to solve the problem. – Slim Down May 4 '16 at 1:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.